WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How to edit my header in Arthemia Theme? (7 posts)

  1. fantasyforte
    Member
    Posted 4 years ago #

    I know you all hear this a lot, but I am very new to all this. I am using the Arthemia theme and would like to customize my site. I am following a Arthemia customization guide (here)but I just don't understand the basics. I don't know where the directory is and I don't know what I'm doing.

    My first project is changing the header. I already have the .jpeg image that I'd like to make as my header, but I don't know how to change it through the editor.

    Here's a link to my site, http://www.fantasyforte.net/

  2. John Hoff
    Member
    Posted 4 years ago #

    First thing you need to do. Back everything up. Trust me, I've been around the block for awhile, stop everything you're doing and back it all up. Backup your WordPress files on your hosting account and backup your database.

    You can use the database plugins: WP db Backup. [spam ink removed]
    Next you'll want to backup all the files on your hosting account. You can simply download them through FTP to your computer or if you know how to zip things up on your web server, just zip them up into a file for safe keeping.

    Now that everything is backed up, I noticed on Arthemia the logo is of type .png, not .jpeg. So if you can convert your .jpeg to a .png file, that would be helpful. If you like, you can link to your image here and I can convert it for you (or perhaps someone else who gets here faster).

    Next take that logo.png file and upload it through FTP to the following dirctory:

    /wp-content/themes/arthemia/images/

    You will be replacing the default logo.png file which came with Arthemia. The trick here is if you want it to snap right in, your image size should be 400px wide and 100px high.

    If you cannot change to a .png (I can for you or here's an online conversion tool) then you'll need to edit your header.php file which you'll find by logging into WordPress dashboard – Appearance – Editor and edit Header (header.php) as that article shows you.

  3. fantasyforte
    Member
    Posted 4 years ago #

    Ok, I did everything you said. I did the coversion tool and then saved it into my documents. I named it logo.png. Through Bluehost's ftp transfer I put my logo.png into http_public/wp-content/themes/arthemia/images/logo.png.

    All that happened was the "arthemia" text became 400px by 100px. This was the original logo.png. The image I converted from jpeg to png did not show up. Did I save it wrong? Is my image incorrect pixels?

  4. fantasyforte
    Member
    Posted 4 years ago #

    But I also just remembered. Earlier (when I was misinformed), I had tried to change the code in the header.php. I changed logo.png to fantasyforte.jpg (saved to my documents). I realize this was a mistake but could that have affected anything?

    After I did the ftp, I switched the fantasyforte.jpg to logo.png.

  5. John Hoff
    Member
    Posted 4 years ago #

    Try replacing the http_public with public_html. So put your image in:

    public_html/wp-content/themes/arthemia/images/logo.png

    I just checked out your site, looks like you got it. To remove the "Just another WordPress Weblog", log into WordPress, go to Settings, click on General and remove your tagline.

  6. spazy
    Member
    Posted 4 years ago #

    the issue is you still have the theme set as your main theme, switch back to a basic default theme, and upload all your changes into the directory of the specific theme.
    click preview to see if it is how you want, then click change once its the way you want it

  7. fantasyforte
    Member
    Posted 4 years ago #

    I got it, thank you all for all your help! My problem was with the bluehost FTP client. When I was selecting the files to transfer, I went in the wrong order and was converting the logo.prg from wp-content to the logo.png I had saved in My Documents.

    I had to google what an FTP client was and study up about it and I used the bluehost instead of filezilla for some reason. It was very exciting when I got it, thank you guys.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.