WordPress.org

Ready to get started?Download WordPress

Forums

How to downgrade back to 2.9.2 from 3.0 (27 posts)

  1. Azzie
    Member
    Posted 3 years ago #

    I upgraded to version 3.0 and Im really frustrated. My site takes extremely long to load after the upgrade, I tried to re-install 3.0 and it just hangs at "unpacking the update..."
    Once im in my admin it takes so long just to go to a different section of the user interface. Seriously im really sorry that I upgraded, and I really want to go back to 2.9.2 can some one help me please

  2. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-specific problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    - increasing the available memory?

  3. James
    Happiness Engineer
    Posted 3 years ago #

    Unless you have a backup that you can restore from, downgrading is an immensely difficult (if not impossible) process, which is why backing up before upgrading is strongly recommended both in the upgrade instructions and automatic upgrade interface.

    It would be better to solve your current problem. Try the basic troubleshooting steps that esmi suggested.

  4. Azzie
    Member
    Posted 3 years ago #

    I Have only one plug in that I use. but I did what you said about deactivating it and it still loads way to slow. even when im logged into the admin its like walking through molasses and it is really frustrating. Before the upgrade I didnt have any of these issues and im really upset that I did because 3.0 is not working for me. Some of my pages take 50 seconds to load and thats just insane im sorry.

  5. jamnkats
    Member
    Posted 3 years ago #

    I have a backup and REALLY want to downgrade also. I have deactivated all my plugins, have DELETED all plugins, I have tried the 2010 theme and I still have problems that have not been addressed yet. I REALLY WANT TO DOWNGRADE!

  6. hatchhunter
    Member
    Posted 3 years ago #

    I tried to upgrade also. Now I recieve a fatal error. I thought that since it was giving me the upgrade option it was a safe thing to do.
    Now I have a fatal error
    Fatal error: Call to undefined function is_multisite() in /home/content/70/5476770/html/wp-includes/wp-db.php on line 505

    Help get me back to the previous install
    Josh McFadden

  7. jamnkats
    Member
    Posted 3 years ago #

    I downloaded 2.9.2 and imported my old database back via phpAdmin but I am still getting those same problems. Dashboard says I'm running 2.9.2 now but I have the same errors from the 3.0 upgrade. ARGH!

  8. ladypzaz
    Member
    Posted 3 years ago #

    I had problems with upgrading plugins on 3.0 and kept getting errors for the last couple of hours, my IP was blocked, and it said it was doing maintenance - VERY FRUSTRATING!!! BUT, I contacted my host and he unblocked me.

    Then, I tried upgrading the plugin once again in 3.0 and the same thing happened! SO, I asked my host to switch me back to an earlier backup of my site which contained 2.9.2 and now it works great!!!!!!!

    Hugs, Patty

  9. hatchhunter
    Member
    Posted 3 years ago #

    Some progress
    I went into my host and at Godaddy and set my site back to 2 days ago. So now it appears to be working but it's forcing me on the backend to upgrade my database. I'm going to allow for my database to be backed up on host this time before even moving forward with this. So far this upgrade has been way more trouble than it'
    s worth.

  10. jamnkats
    Member
    Posted 3 years ago #

    I think I'll ask my host to set me back 2 days also. I cannot get rid of these errors and they have nothing to do with plugins.

  11. jamnkats
    Member
    Posted 3 years ago #

    OMG I got it to work!! I'm back to 2.9.2 and didn't have to have the hosting company roll me back. Unfortunately I have no idea what did it. I made changes to config.php and htaccess. It never was a plugin issue.

    OMG, It is FIXED (and running 2.9.2)!!! Well, that only took All Day.

  12. bitkahuna
    Member
    Posted 3 years ago #

    downgrading was cake. i overlaid the 3.0 dirs wp-admin, wp-include and all root files with 2.9.2 versions and when going to login it said it needed to make database 'upgrades' which i let it, and then everything worked fine.

  13. Armin100
    Member
    Posted 3 years ago #

    I need to downgrade too, How can I do this.

    Problems have occurred with my theme due to this upgrade.

  14. dogstar foundation
    Member
    Posted 3 years ago #

    Hi I need to downgrade as well as the upgrade is really making my site behave oddly

    I am not very techie and the sole person who looks after my website ( Its Charity website ) I am hosting with Godaddy so interested in the option to set the website back 2 days

    Who in Godaddy do i need to speak with and what do I need to ask for

    Many Thanks

  15. rluquis
    Member
    Posted 3 years ago #

    bitkahuna is GOD.

    I did what you said, and I have WordPress 2.9.2 back.

    Thanks a lot man.

  16. Dzynit
    Member
    Posted 3 years ago #

    Regarding hatchhunter's issue, thought this info might be useful to anyone that runs into the same kind of problem.

    This happened to me yesterday, so I rolled back to 2.9.2. (Just by re-uploading the 2.9.2 files.) Then upgraded the plugins first - then wordpress to 3.0 and all went well.

    For me it was the Events Calendar plugin. Upgrading it first cured the incompatibility it had with 3.0.

    So if you have a plugin that hasn't been setup to be compatible with 3.0 yet, best recommendation is to hold off on the upgrade till the plugin is unless you don't mind just deactivating it.

  17. paulvw
    Member
    Posted 3 years ago #

    THANKS BITKAHUNA!!!! The UAM plugin messed up 3.0 (or the other way around :-) but downgrading to 2.9.2 solved the problem!

    Thank you so much!

  18. hydrovibe
    Member
    Posted 3 years ago #

    Thank you as well, Bitkahuna!

    I'm working on a site that unfortunately is hosted with Yahoo. The site's been acting strange ever since upgrading to 3.0. Your steps worked perfectly. For those of you whose downgrade didn't work - be sure to delete your old config file.

    Again, thanks!
    Heather

  19. FoxyCitrus
    Member
    Posted 3 years ago #

    Hi!

    How would I set my site back two days if it is hosted through Word Press?

    Thanks,
    Lauren

  20. newdivorcetactics
    Member
    Posted 3 years ago #

    Frickin' 3.0 Has killed me! Thanks to BITS's advice above, I am rolling back ALL of my sites to WP 2.9.2, and so far so good. Will try Dizynit's advice on upgrading, but only one at time and on a site I don't care about FIRST! Truly amazed at how little there is on the web re: this problem, and the incurable ERROR CODE 324!

  21. m4512ur
    Member
    Posted 3 years ago #

    I'm frustated when upgrade my wp blog with ver.3.0 It seems not all themes was compatible with WP 3.0. My widget didn't work. I need to downgrade too.

  22. projectheresy
    Member
    Posted 3 years ago #

    +1 Bitkahuna.

    I over-wrote the wp-admin and wp-includes and the root WP folder files EXCEPT wp-config.

    Refreshed admin screen, updated DB, et, voila.

  23. chasemann
    Member
    Posted 3 years ago #

    I upgraded from 2.9.2 to 3.0.2 and now I can't set pages to sub-page via the new Menu area. My pages still show up in the theme that I use and are accessible in it, but if I switch themes, then the sub-pages get all messed up and I had to revert to a back-up.

    How can I make the new menus work in 3.0.2?

    Thanks, Chase.

  24. Corsari
    Member
    Posted 3 years ago #

    I've automatically upgraded from 2.9.x to 3.0.3

    Looks like that post tags are not working.

    I can add a tag but only in the tags management while it is not working from the post, anyway, bad new, this is useless because later, from the post editing, choosing from popular tags doesn't work.

    In few word, in my case, the tags div on the right of the new post page is not working.

    The text field where to write the tags, is by default filled with a gray text: "add a new tag", starting typing should make it disappearing, but it is not.
    - You write something but next the Add button does nothing
    - Clicking the link "choose a tag from the most used", scrolls the page up and doesn't show any tag
    - Clicking "suggested tags related to the content" makes the animated mac style processing icon to appear but then, after a couple of seconds, it disappear and nothing happen

    Any tip to fix this is welcome otherwise a downgrade is a must

    For those who want to downgrade, looks like that bitkahuna user solution works read above
    downgrading was cake. i overlaid the 3.0 dirs wp-admin, wp-include and all root files with 2.9.2 versions and when going to login it said it needed to make database 'upgrades' which i let it, and then everything worked fine.

    Thank you
    Robert

  25. Christiaan
    Member
    Posted 3 years ago #

    Di

  26. dennispolman
    Member
    Posted 3 years ago #

    Thanks projectheresy and bitkahuna!

    I over-wrote the wp-admin and wp-includes and the root WP folder files EXCEPT wp-config.

    My whole site was dead because of the update WP 3.1

    Thanks again!
    Cheers from Holland!
    Dennis

  27. Happeh
    Member
    Posted 3 years ago #

    Ya bitkahuna's instructions work. Copy everything except the config file over and it will work.

    To avoid any additional problems you might want to set the theme to the classic theme. I got error messages with both the theme that was being used and the twentyten theme.

    I am pretty sure I can confirm the posters talking about 3.0 being slow. After performing the downgrade to 2.92 the website snaps right back after any command. Before it was really dragging.

Topic Closed

This topic has been closed to new replies.

About this Topic