WordPress.org

Ready to get started?Download WordPress

Forums

How to disable permalink definitively ? (21 posts)

  1. GuiPoM
    Member
    Posted 8 years ago #

    Hello !

    I have installed wordpress on a free.fr account, and htaccess with url rewriting seems not to be accepted. But each link on my blog still is a permalink and on my admin panel, if I try to suppress permalink, I have got a 500 internal error and I must suppress the new htaccess in order to get back to site ... with each link as a permalink. I tried to search in php files what is done in permalink part in order to solve that problem, but I couldn't find.

    Thanks for your help ;)

  2. viitoria
    Member
    Posted 8 years ago #

    Explain what you want a bit better. You're running on with really long sentences. Do you want to get rid of the customized permalinks altogether (like you customized them before) or...?

  3. James
    Happiness Engineer
    Posted 8 years ago #

  4. viitoria
    Member
    Posted 8 years ago #

    So you want permalinks to work but the htaccess isn't writing? (because that whole disabling title thing is throwing me off).

    Try this:

    1 - upload empty .htaccess to blog root
    2 - chmd to 777
    3 - define new permalink structure in options
    4 - chmd back to 644 (or whatever permissions were before)

  5. GuiPoM
    Member
    Posted 8 years ago #

    I wanted to use permalink and an htaccess file is created BUT when the file is created then server gives back a 500 error. I have to delete htaccess then to be able to connect to my site.

    When this is done, links are still permalink and in admin console permalink are still used.

    So I suppress them and ... 500 internal error .... ..... ......

  6. James
    Happiness Engineer
    Posted 8 years ago #

    First, try what Viitoria suggested.

    If that doesn't work, go back to Options/Permalinks, delete your .htaccess file, clear the data in the "Structure:" field, and hit "Update Permalink Structure".

    Once some order is restored, try setting your permalinks with /index.php/ at the the front of the structure.

  7. GuiPoM
    Member
    Posted 8 years ago #

    ....

    If that doesn't work, go back to Options/Permalinks
    delete your .htaccess file >> ok that's what i explained before

    clear the data in the "Structure:" field and hit "Update Permalink Structure" >> 500 internal error

    and now ? ;)

  8. James
    Happiness Engineer
    Posted 8 years ago #

    Did you delete the .htaccess file first? If you did, then that should have given you a working site with the default permalink structure. If you didn't, then it would return 500 error.

  9. GuiPoM
    Member
    Posted 8 years ago #

    I delete my htacces, the site with working but with an incorrect permalink structure

    for example on main page, "ma-machine" is still there, it was articleid1 or something like that before

    and in admin page, still something in permalink even if htaccess was deleted

  10. roterhund
    Member
    Posted 8 years ago #

    >> and in admin page, still something in permalink even if htaccess was deleted
    Have you tried deleting what's in the textbox before hitting "update permalink structure"?

  11. GuiPoM
    Member
    Posted 8 years ago #

    of course

  12. GuiPoM
    Member
    Posted 8 years ago #

    any idea of where is stored permalink configuration to manually delete it ?

  13. ges
    Member
    Posted 8 years ago #

    hello i have exactly the same problem (totally the same as you described it) on free.fr. did you find a solution to the problem? i too tried to find the stored permalink configuration but just couldn't find it.

    any help would be great.
    thanks

  14. oriecat
    Member
    Posted 8 years ago #

    Do you mean where in the database? wp-options table

  15. ges
    Member
    Posted 8 years ago #

    I'm trying to get back to where I was before I tried the permalinks. apparently you can't mod-rewrite ot chmod with free.fr, my provider.

    but i can't find a php file where the information is stored to go back. and like guipom mentioned -

    'I wanted to use permalink and an htaccess file is created BUT when the file is created then server gives back a 500 error. I have to delete htaccess then to be able to connect to my site.

    When this is done, links are still permalink and in admin console permalink are still used.

    So I suppress them and ... 500 internal error .... ..... ...... '

    i have the same problem.
    any help would be great.

  16. TechGnome
    Moderator
    Posted 8 years ago #

    Try it in this order:
    1) Go into options and clear the text box that has the perma link structure.
    2) Click the Update button
    3) Connect by FTP and DELETE the .htaccess file there.
    Everything should be back to normal at that point. I think what might be happening is that you delete the htaccess file, but then update the permalinks and so it's getting recreated (even though it's blank)

    -tg

  17. ges
    Member
    Posted 8 years ago #

    that's exactly what i did. and even after i delete the htaccess file, the home page works fine but if i click on any post or page it still tries to find them at a permalinks address and thus doesn't find them (even with no htaccess file). so i'm trying to find out where this information is stored to go back to the original configuration.
    i hope this is a bit clearer.
    thanks.

  18. Ryan Duff
    Member
    Posted 8 years ago #

    ges: if its still giving you permalinks on your homepage, and the permalink structure is empty, try refreshing the page. Sounds like you're looking at a cached page.

  19. ges
    Member
    Posted 8 years ago #

    ryanduff: i tried that too, but no dice.
    but i seem to have solved the problem by trying the same thing quickly. deleting the htaccess file and setting permalinks to '' nearly at the same time.
    bizarre, but it got rid of the "stored" permalinks info.
    thanks everyone for your help.

  20. jamesfiv
    Member
    Posted 8 years ago #

    I have a somewhat different problem.

    I wanted to use a plugin called Category Order from:
    http://www.buzolich.com/techtips/category-order/.

    The typical bug doesn't let one see the categories if Permalinks are enabled. I went to the Options page, but that is not an option.

    I tried changing the preferences for permalinks, selected the custom option, and changed the .htaccess file with the given script.

    That made all links in the blog that were connected to the blog itself inactive. Even the comments page gave an error.

    Ok, I have set all things back to normal and permalinks back to default, no problems there anymore. But I still have not figured out how to disable permalinks.

    The above suggestions of eliminating the .htaccess file are not an option, because it is needed for other functions - the custom 404 page for example.

    Any other options?

  21. Oezratty
    Member
    Posted 7 years ago #

    I went into the same problem and found a solution.

    First, what's the problem? When changing the Permalinks in Admin/Options/Permalink, I get this page error. All the site was then disabled. I then deleted the .htaccess file and the home page was working again. But the links didn't work.

    I then found out that the wp_options table contained an option: permalink_structure that had an option_value containing the file pattern (%blablah). I used the MySQL admin engine from Free and deleted this field in the row. Then everything went back to normal with the default permalink structure with pages numbers.

    However, I still wonder what's wrong in the first place. It may be due to the way Free has configured its Apache and MySQL servers.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.