WordPress.org

Ready to get started?Download WordPress

Forums

How to disable "leave a reply" section to a blog post?? (6 posts)

  1. mixmastermichael
    Member
    Posted 4 years ago #

    Hi there,

    On my blog, I would like to disable comments that are available to readers for now.

    In my settings, I have unchecked "Allow people to post comments on new articles", but the leave a reply is still showing up in my blog posts.

    Can someone please take a look and let me know what the problem could be?

    Here is an example of one of the posts.
    http://blog.iongeo.com/?p=223

    I would greatly appreciate any help that could be provided.

    Thank you.

  2. MichaelH
    Member
    Posted 4 years ago #

    You may need to uncheck the Allow comments on this post in the Discussion module that is available on each post.

  3. Brad
    Member
    Posted 4 years ago #

    you will probably need to remove the comment code from the post and pages.

    [solicitation removed MEH]

  4. Shane G
    Member
    Posted 4 years ago #

    Hi,

    It seems that comment posting is still enable on your blog and post hence it gibes the post a comment option on your posts. Hence, you need to disable post comment option from wordpress admin area -> settings -> discussion as well as from post page.

    Thanks,

    Shane G.

  5. mixmastermichael
    Member
    Posted 4 years ago #

    Ah thanks MichaelH and crea8tive.

    Now a few follow up questions, might there be a way to have that "Allow comments for post" is unchecked for all posts?

    Also, can you please provide me what code I might need to modify if I want to comment out the "comments" section of the php?

    Thanks

  6. MichaelH
    Member
    Posted 4 years ago #

    Backup your database.

    Use phpMyAdmin with this SQL to turn comments off on all posts and pages

    UPDATE wp_posts SET comment_status='closed' WHERE post_status = 'publish' AND post_type = 'post';
    UPDATE wp_posts SET comment_status='closed' WHERE post_status = 'publish' AND post_type = 'page';

    You will probably be looking for Template_Tags/comments_popup_link in your themes template files -- need to delete that.

    Related:
    Stepping Into Template Tags
    Stepping Into Templates
    Template Hierarchy
    WordPress Backups

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.