WordPress.org

Ready to get started?Download WordPress

Forums

Mantra
[resolved] How to disable "leave a post" (5 posts)

  1. Eduard-i-Silvia
    Member
    Posted 1 year ago #

    Hi all, I would like to know how to disable the option to leave a post or comment in a page. I want to create mi first web with no posts in most of the pages, maybe one page for articles and comments, just one.

    I guess it is so simple but I can't find it anywhere. Sure it is because I'm still learning WP concepts and options and Mantra is just the second theme I have used for that learning process, another newbie.

    Thanks.

  2. ModularBase
    Member
    Posted 1 year ago #

    In your Admin, go to Settings > Discussion.
    Deselect "Allow people to post comments on new articles", the "Save Changes" button at bottom. This disables comments on Pages and Posts.

    For the Page you want comments on, when you create that page, select "Allow comments." in the Discussion box. For Posts, do the same for each post you make.

    There is a way using CSS, but this may be simpler if you're just starting with WordPress.

  3. Eduard-i-Silvia
    Member
    Posted 1 year ago #

    Hi ModularBase, thanks a lot for your help, it was easy really :-)

    But the fact is that I already unchecked that option a couple of days ago and nothing changed in the appearence of my pages. I thought I was a dummy because I couldn't change the pages format even when the option was there and I kept it disabled all the time.

    Anyway, I have discovered something: what happens to me is that the old pages I created before look the same (with the ability to comment them). Only the pages I create from now on are ok. I guess it has been some kind of bug because of the so many changes of themes I have made in my process of learning. Is it possible?

    Maybe I should delete all the web files and install WP and Mantra again but... what if it happens to me when I publish my web? Oh God, what a mess!

  4. ModularBase
    Member
    Posted 1 year ago #

    Go back to the pages which allow comments and deselect the "Allow comments." in the Discussion box. Do this for each page and at the bottom of the page when you view it, you will see "Comments Closed"

  5. CryoutCreations
    Member
    Theme Author

    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.