WordPress.org

Ready to get started?Download WordPress

Forums

how to disable image url link (permalink) in WP gallery posts? (8 posts)

  1. shiatostorm
    Member
    Posted 6 years ago #

    I've got the gallery in a post working in an acceptable way unfortunately I can't seem to locate where I can turn disable the code that makes a link out of the image that when you click it goes to the image on a completely blank page, which I assume is the permalink for where images reside in the uploads folder...
    I just want people to be able to click the thumbnails in a post, see a larger image and then go no further, any advice on how to turn this feature off would be greatly appreciated.
    please see here for where I am trying to implement this:
    http://www.lightoverwater.co.uk/blog/?p=486

  2. Os..
    Member
    Posted 6 years ago #

    same here. Maybe we find it somewhere in the wp-include files..

  3. Os..
    Member
    Posted 6 years ago #

    same here. Maybe we find it somewhere in the wp-includes.. I thought, but now i think it already happens in the tinymce editor... cant find it yet.

  4. Os..
    Member
    Posted 6 years ago #

    overlooked by myself, heres the solution:
    http://codex.wordpress.org/Using_Image_and_File_Attachments

    search for explanation:
    # Not Linked means the image will simply appear in the post without any kind of hyperlink attached to it (if a visitor clicks on it, it will not take them to another page.)

    means, klick "None" where it saxs: Enter a link URL or click above for presets.

  5. shiatostorm
    Member
    Posted 6 years ago #

    Yes, I was aware of this, yet even with this option selected it seems my images can be clicked on all the way through to a blank page and just the image...

  6. Os..
    Member
    Posted 6 years ago #

    Hi shiatostorm,
    do you mean in galleries? The link seems to reappear in the galleries media upload thing. When in text, clicking on an picture in the editor and editing its options it doesnt here..

  7. lonlomba
    Member
    Posted 5 years ago #

    Hi,

    I realize this post is 5 months old, but I am having the same issue, and it would be great to solve.

    Specifically, I create a post with a gallery of images. I leave the "Enter a link URL or click above for presets." form field blank. However, on the 'attachment page', the image is clickable, and goes to an ugly image only page.

    Is there any way to disable the link or set the link on the attachment page?

  8. mikeque
    Member
    Posted 5 years ago #

    I too need to correct this. I understand how to insert an image with no link, or to link to a file, but my client accidentally links it to this page via the "post URL" button.

    On clicking the image, this presents a page that is broken with comment posts, and seems to be unrelated to anything in my theme. I have no way to disable this feature nor to edit the page.

    Adding attachments.php to the them folder has no effect whatsoever.

Topic Closed

This topic has been closed to new replies.

About this Topic