WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
[resolved] How to disable FULL TEXT indexing of YARPP (5 posts)

  1. irfanbostanci
    Member
    Posted 5 months ago #

    I only use tags to create related posts. I dont want to use FULL TEXT indexing of YARPP and I want to remove it completely. Even if remove the indexes yarpp_title and yarpp_content, they get created automatically again. I chose the option to use tags only and i still have this problem. Do you know a permanent solution for my problem (switching db engine to INNODB is not an option because i use FULL TEXT indexing for some other purposes)

    https://wordpress.org/plugins/yet-another-related-posts-plugin/

  2. jeffparker
    Member
    Plugin Author

    Posted 5 months ago #

    Do you have "Do not consider" selected for both Titles and Bodies?

  3. irfanbostanci
    Member
    Posted 5 months ago #

    Yes. This is the yarpp options value in wp_options if that may help

    a:47:{s:9:"threshold";s:1:"1";s:5:"limit";s:1:"5";s:14:"excerpt_length";s:2:"10";s:6:"recent";b:0;s:12:"before_title";s:4:"<li>";s:11:"after_title";s:5:"</li>";s:11:"before_post";s:8:" <small>";s:10:"after_post";s:8:"</small>";s:14:"before_related";s:4:"<ul>";s:13:"after_related";s:5:"</ul>";s:10:"no_results";s:23:"<p>İlgili soru yok</p>";s:5:"order";s:10:"score DESC";s:9:"rss_limit";s:1:"5";s:18:"rss_excerpt_length";s:2:"10";s:16:"rss_before_title";s:4:"<li>";s:15:"rss_after_title";s:5:"</li>";s:15:"rss_before_post";s:8:" <small>";s:14:"rss_after_post";s:8:"</small>";s:18:"rss_before_related";s:29:"<h3>İlgili sorular:</h3><ul>";s:17:"rss_after_related";s:5:"</ul>";s:14:"rss_no_results";s:24:"<p>İlgili soru yok.</p>";s:9:"rss_order";s:10:"score DESC";s:9:"past_only";b:0;s:12:"show_excerpt";b:0;s:16:"rss_show_excerpt";b:0;s:8:"template";b:0;s:12:"rss_template";b:0;s:14:"show_pass_post";b:0;s:12:"cross_relate";b:0;s:11:"rss_display";b:1;s:19:"rss_excerpt_display";b:1;s:13:"promote_yarpp";b:0;s:17:"rss_promote_yarpp";b:0;s:15:"myisam_override";b:0;s:7:"exclude";s:0:"";s:6:"weight";a:1:{s:3:"tax";a:1:{s:8:"post_tag";i:1;}}s:11:"require_tax";a:0:{}s:5:"optin";b:0;s:18:"thumbnails_heading";s:14:"Related posts:";s:18:"thumbnails_default";s:98:"http://www.soranzi.com/sablon/wp-content/plugins/yet-another-related-posts-plugin/images/default.png";s:22:"rss_thumbnails_heading";s:14:"Related posts:";s:22:"rss_thumbnails_default";s:98:"http://www.soranzi.com/sablon/wp-content/plugins/yet-another-related-posts-plugin/images/default.png";s:12:"display_code";b:0;s:20:"auto_display_archive";b:0;s:23:"auto_display_post_types";a:0:{}s:5:"pools";a:0:{}s:25:"manually_using_thumbnails";b:1;}
  4. irfanbostanci
    Member
    Posted 5 months ago #

    My problem is solved. When i checked wp_options table i saw that 'yarpp_fulltext_disabled' with value '1' was missing there. I added that row and it is disabled now. I cloned this site from a template and for some reason that row couldnt be copied (the other 4 yarpp options got copied without problem) to my new database.

    I hope this helps if anyone comes across this problem by any chance.

    Have a nice day !

  5. jeffparker
    Member
    Plugin Author

    Posted 5 months ago #

    Good to know!

Reply

You must log in to post.

About this Plugin

About this Topic