WordPress.org

Ready to get started?Download WordPress

Forums

Wordfence Security
[resolved] How to disable FAKE GOOGLE CRAWLER when you can't access settings through ADMIN? (4 posts)

  1. cmonster
    Member
    Posted 1 year ago #

    I get locked out of my site with the FAKE GOOGLE CRAWLER error but I can't log into the site with the plugin activated because I keep getting an INVALID KEY error whenever I go through the process of requesting a reset through the Wordfence site. Uninstalling and reinstalling the plugin doesn't help. How do I get Wordfence to work again?

    (I posted the same question on the Wordfence site a few days ago).

    http://wordpress.org/extend/plugins/wordfence/

  2. Darin
    Member
    Posted 1 year ago #

    Having the same exact issue... on several sites. Wound up nuking the entire wordfence directory within the plugins folder. Seemed like a great idea but work about as good as a steaming pile of #$%^.

  3. Wordfence
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    We tend to give a faster response on our http://www.wordfence.com forums and you can get priority email support as a paid customer.

    You were probably locked out of your site because you enabled the option to block Fake google crawlers and for some reason your browser is sending a Googlebot user agent i.e. pretending to be Google. This config is usually used by developers who want to see their site as Google sees it.

    So disable the option to block fake crawlers and don't use it again.

    Regards,

    Mark.

  4. RonDsy
    Blocked
    Posted 1 year ago #

    The fake Google crawler firewall routine is unforgiving in that it locks the site and leaves a nasty screen. I do not know how practical this method will assist the client's safety while leaving the site inaccessible to the public, client and admin. Ultimately the outcome makes the admin or site developer look bad.

    Our staff concerning WordPress matters at Talking Manuals is observing complaints that the fake Google crawler firewall routine within Wordfence does more harm than good, in that it locks the entire site down and bars access to all for no apparent security reason. To unlock the site, you must strong arm and FTP to rename Wordfence. What is theoretically is a good thing, backfires.

    When seen through the eyes of the client and the viewing public this kind of security measure is usually too harsh, unacceptable and embarrassing.

    Possibly a better way is to block site accessibility for a set time upon detection of a fake Google crawler (and flag a report to the admin), then unblock and allow access. At present state, I would suggest Wordfence users not set this routine as active.

    see complete product reviews for Wordfence: http://talkingmanuals.com/wordpress-plugin-reviews/wp-security

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic