WordPress.org

Ready to get started?Download WordPress

Forums

How to delete the Leave a Reply form from TwentyTen pages? (13 posts)

  1. Boz2006
    Member
    Posted 1 year ago #

    I'm using the TwentyTen default theme.

    I need to remove the Leave a Reply form from various (but not all) pages.

    Is there a simple way of doing this?

    Many thanks.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Don't edit the Twenty Ten theme. You need to create a child theme for your changes.

  3. Boz2006
    Member
    Posted 1 year ago #

    I'm sorry, but that's beyond my skill level.

    Is there a simple way of not allowing Leave a Reply on my pages, and just allowing visitors to leave a comment on the Blog page?

    It seems odd that Leave a Reply is on all pages by default.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    You could just disable commenting via Settings -> Discussion. You will also have to uncheck "Allow comments" in the Discussion pane on the Edit page of each existing Post or Page. If you do not see this pane, click Screen Options at the very top of the page and check "Discussion".

  5. Boz2006
    Member
    Posted 1 year ago #

    Thank you, that's very helpful.

    I don't see in Settings -> Discussion any way of disabling comments, but unchecking Allow Comments works on the edit page of each existing page.

    However, even if I Allow Comments on the Post page, there doesn't seem to be any visible option to allow a visitor to Comment.

    If they click on 1 Comment, then, yes, they can comment, but there isn't an invitation to comment. I assume it is designed this way on purpose?

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    See Settings -> Discussion -> Allow people to post comments on new articles

  7. Boz2006
    Member
    Posted 1 year ago #

    Many thanks.

    Last question: what does Article refer to in the Word Press jargon?

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    Where did you see the reference to "article"?

  9. Boz2006
    Member
    Posted 1 year ago #

    Settings / Discussion Settings / Default Article Settings in the Twenty Ten theme.

  10. esmi
    Forum Moderator
    Posted 1 year ago #

    Ah! That will be Posts.

  11. Boz2006
    Member
    Posted 1 year ago #

    Many thanks, that makes it clear.

    I realise that a similar question about the Twenty Eleven theme ought to be in a separate thread, but I'm having the same problem in that theme with trying to find the option, on pages, to not allow comments.

    Looking at Screen Options, and ticking Comments doesn't help.

    Do you have any ideas? In other words, on some pages, I don't want to have Comments available. Could you please advise me how to do this?

  12. esmi
    Forum Moderator
    Posted 1 year ago #

    Looking at Screen Options, and ticking Comments doesn't help.

    You have to then uncheck "Allow comments" in the Discussion pane on the Edit page of each existing Page.

  13. Boz2006
    Member
    Posted 1 year ago #

    Great! Many thanks for your help.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.