WordPress.org

Ready to get started?Download WordPress

Forums

Opulus Sombre
How to customise the font (7 posts)

  1. Rascal87
    Member
    Posted 5 months ago #

    I'm relatively new to wordpress with a basic understanding of CSS, HTML etc. I've pretty much finished my site, just adding the last images and final touches. Really want to use a custom font (not google etc) with the Opulus Sombre Theme, having tried several tutorials I still can't seem to use a custom font for this theme.

    I've uploaded the font files and tried to change the font family in the pages but can't seem to get it to work. I know I probably need to change the themes CSS but can't see what it is in the CSS that i need to change.

    Any suggestions? if you solve this then you are my hero :)

  2. salsaturation
    Member
    Posted 5 months ago #

    Hi Rascal

    If possible please provide a link to your site and the font and maybe the code (via pastebin.com) you have implemented.

  3. Rascal87
    Member
    Posted 5 months ago #

    http://ld-designs.co.uk/
    font i like is Sansation ( i have it in all formats)
    http://pastebin.com/e4rAey3L copy of the CSS

    Also please note my website is a complete mess right now lol.

    Thanks

  4. salsaturation
    Member
    Posted 5 months ago #

    I don't see any mention of Sansation in your css or source code... how are you implementing it?

  5. Rascal87
    Member
    Posted 5 months ago #

    yeah, sorry i forgot i took it back out, as it did nothing. I've tried using the whole @font method in the Opulus Sombre Theme CSS. I also uploaded it to my directory then was told just to edit the 'font-family' in the page text from Helvetica to Sansation and that didn't work. so now I'm pretty sure i can put it in the CSS i copied just not sure where as when i try it still reverts back to Helvetica, Arial etc :/

  6. batharoy
    Member
    Posted 5 months ago #

    You still need to apply it to page elements for it to take affect.

    body {
        font-family: 'sansationregular';
    }
  7. Rascal87
    Member
    Posted 5 months ago #

    finally got some free time to try this again, it now works properly using the @fontface method- just had to put it in the 'general settings' part of Opulus Sombre CSS, upload font files to theme folder and Had to use

    '<span style="font-family: sansationregular; font-weight: normal; font-style: normal;">'

    No idea why this didn't work before but it's there for anyone else who's having trouble... Thanks for your comments ppl

Reply

You must log in to post.

About this Theme

About this Topic