WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How to copy or upload files for upgrade (10 posts)

  1. jbrine1
    Member
    Posted 4 years ago #

    I'm trying to upgrade to most current version. I've backed everything up. I've downloaded and extracted the files for 2.9.2. Now I'm supposed to copy the files to my server. I go to upload the files through my cPanel. (Forgive me I am a beginner at this.) Do I have to upload each file one by one? Is there a way to upload files in batches?
    Any help would be appreciated.

  2. Micah Cooksey

    Posted 4 years ago #

    You can use an FTP client. Basically, you want to replace everything but the your wp-content folder. You want to upload the three index.php files contained in that folder: the one in /wp-content/, the one in /wp-content/themes/, and the one in /wp-content/plugins/.

  3. Shane G.
    Member
    Posted 4 years ago #

    Hi,

    Refer this article:

    http://codex.wordpress.org/Upgrading_WordPress

    Also check with this plugin for automatic upgrade:

    http://wordpress.org/extend/plugins/wordpress-automatic-upgrade/

    Thanks,

    Shane G.

  4. jbrine1
    Member
    Posted 4 years ago #

    Thanks to micahcooksey and Shane G.
    I tried filezilla as an FTP client. Uploading the files went smoothly but my site is not letting me open it. I get various warnings when I go to my wp/admin:

    Warning: include_once(/home/juliabri/public_html/wp-includes/streams.php) [function.include-once]: failed to open stream: No such file or directory in /home/juliabri/public_html/wp-settings.php on line 164

    Warning: include_once() [function.include]: Failed opening '/home/juliabri/public_html/wp-includes/streams.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/juliabri/public_html/wp-settings.php on line 164

    Warning: include_once(/home/juliabri/public_html/wp-includes/gettext.php) [function.include-once]: failed to open stream: No such file or directory in /home/juliabri/public_html/wp-settings.php on line 165

    Warning: include_once() [function.include]: Failed opening '/home/juliabri/public_html/wp-includes/gettext.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/juliabri/public_html/wp-settings.php on line 165

    Fatal error: Class 'NOOP_Translations' not found in /home/juliabri/public_html/wp-includes/l10n.php on line 437

    Any ideas what I should do?
    Should I try to restore my old site and try again? Thanks again for any help.

  5. Micah Cooksey

    Posted 4 years ago #

    Did you go to yourdomain.com/wp-admin/upgrade.php after you uploaded the files? That would do it if you didn't (don't feel bad, it's my fault for forgetting to tell you :) You could also try replacing everything in your wp-includes folder with the contents from a fresh donwload, but if that doesn't work, do the following steps:

    • Download WP again from http://wordpress.org/download
    • Upload and replace all the files in your main directory
    • Replace all the contents of your WP-Admin folder
    • Replace all of the contents of your WP-includes folder (again)
    • Replace the index.php file from WP-Content in the download and place it in the same folder in filezilla
    • Do the same with the index.php files from the plugins and themes folders

    Let me know if that works for you.

  6. jbrine1
    Member
    Posted 4 years ago #

    Nope. I'm afraid I'm all scrambled up now. I wasn't sure what you meant by "upload and replace all the files in your main directory" but I did replace all the contents of my WP-Admin, wp-includes and wp-content folders. All the folders in my /public_html folder have big black question marks on them and I can't log into my wp-admin. Thanks again for trying to help me.

  7. s_ha_dum
    Member
    Posted 4 years ago #

    Black question marks? Do you see anything about users or permissions? In Filezilla, you might have to right click on the server header bar (where is says things like 'Filename', 'Filetype', 'Last Modified', etc.) and check the 'Permissions' and 'Owner/Group' boxes.

  8. jbrine1
    Member
    Posted 4 years ago #

    I went to File Attributes and the permissions seem to be ok.

  9. jbrine1
    Member
    Posted 4 years ago #

    I cleared almost all the question marks by double clicking on the folders in filezilla, all except the ones for Sourceguardian and Ioncube. I suspect the question marks are just a red herring. My real problam - not being able to get to my site or wp-admin - lies elsewhere.

  10. jbrine1
    Member
    Posted 4 years ago #

    My web host is going to restore my site from a backup. Then I'll start over.

Topic Closed

This topic has been closed to new replies.

About this Topic