WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How to configure Offloading static content (7 posts)

  1. xinfo
    Member
    Posted 4 years ago #

    Hello every one

    i am trying to offload my static content to my sub domain

    i am fllowing this page
    http://codex.wordpress.org/WordPress_Optimization/Offloading

    well i want to have multiple hostnames to store my media

    Eg: s1.mydomain.com for image
    s2.mydomain.com for video
    s3.mydomain.com for other files

    what i should configure in
    Admin-setting-Miscellaneous Settings-Uploading Files

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    WordPress doesn't distinguish between attachments in that way. Pick one domain only, or write a plugin to do this sort of thing.

  3. xinfo
    Member
    Posted 4 years ago #

    otto

    if i pick one sub-domain

    do i have to fill

    Store uploads in this folder

    or

    Full URL path to files

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    Both.

    The first one tells WordPress where to move the uploaded files to. So if they need to be in some special directory to be on the subdomain, then that's where you fill that in.

    The second one is the URL prefix for the files, where you'd put in the subdomain and path name that they should get on the site, starting with http: and everything.

    Actually setting up the subdomain is up to you.

  5. xinfo
    Member
    Posted 4 years ago #

    ok

    plz check whether my path is right

    if i upload the files to my sub-domain (s1.mydomain.com)

    and folder called images(s1.mydomain.com/images/)

    i should fill the option like

    Store uploads in this folder

    /images

    Full URL path to files

    http://s1.mydomain.com/images

    if it's wrong let me know

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    It won't be "/images" unless you really have the images directory in the root of the server.

    The normal value for that field is "wp-content/uploads". Note the lack of the leading "/". If you leave off the leading /, then it assumes you're starting from the WordPress root directory. With the leading /, it assumes the root of the filesystem.

    So make sure the path to the folder is correct given that.

  7. xinfo
    Member
    Posted 4 years ago #

    Thank you so much for your patients i under stand now

    once i am success i post it here

    Thank you again

Topic Closed

This topic has been closed to new replies.

About this Topic