WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] error on xampp local install (10 posts)

  1. Cathy Tibbles
    Member
    Posted 6 years ago #

    I have an apache server running locally. PHPmyadmin is running, apache and mysql are running. the Wp folder is in the right place - htdocs. When I try to go to http://localhost/wordpress/ I get this message:
    The requested URL /wordpress/ was not found on this server.

    Any idea why? I don't think it is a xampp/ apache problem so I've come here. I've followed podz tutorial 3 times, but no luck (since I imported the db).

  2. whooami
    Member
    Posted 6 years ago #

    how to change wp password on a local install?

    what does that error have to do with a password?

  3. Cathy Tibbles
    Member
    Posted 6 years ago #

    I forgot to edit the thread title when I was finished writing. It's done now.

  4. Cathy Tibbles
    Member
    Posted 6 years ago #

    The requested URL /wordpress/ was not found on this server.
    Why is Xampp not finding my WordPress installation? I put it under xampp/htdocs/wordpress. When I go to http://localhost/wordpress/install.php - i get a connection to wordpress saying it is already installed. But I can't get to the index??

    thanks,
    Cathy

  5. whooami
    Member
    Posted 6 years ago #

    http://localhost/wordpress/install.php isnt the right url.

    http://localhost/wordpress/wp-admin/install.php is the right url

    is that what you mean?

    im not stressing the details to be hard on you; its difficult enough for us to help with local installs. We cant see "see" your install, so you have to be as specific and accurate as you can be when you describe things.

  6. Cathy Tibbles
    Member
    Posted 6 years ago #

    Thanks for reading, Whooami. I appreciate whatever help i can get!
    at /wordpress/wp-admin/install.php I have no problem - i get the wordpress page saying that it is already installed.

    at /wordpress/wp-admin/, the browser immediately redirects to my live site at http://www.tibbles.net/blog/ (and then of course, it can't find anything because of the different root drives for the blog - "wordpress" and "blog" is the live one.)

    I've triple checked the wp-config file, and the location of the wordpress local files. I can't figure out what else to check.

    -apache is running
    and so is mysql

    And sql has successfully imported my wp database file. All records appear to be there.

    Any other ideas?

  7. jabecker
    Member
    Posted 6 years ago #

    And sql has successfully imported my wp database file. All records appear to be there.

    Having been through this myself, I'm betting that the options in the database from your live site probably point to the live site's url. You need to edit the database so that it points to your local blog. I'd start with prefix_options siteurl.

  8. Cathy Tibbles
    Member
    Posted 6 years ago #

    thank you - i can now get to the login screen. I will have to re-load wordpress, as I've lost the admin password - unless there's a better option?

    thanks so much,
    Cathy

  9. whooami
    Member
    Posted 6 years ago #

  10. Cathy Tibbles
    Member
    Posted 6 years ago #

    I ended up doing it all over again. I downloaded the latest version from wordpress - it is what I'm running live. And downloaded the latest xampp. Reloaded it all, exported from wordpress, and imported into a new database.

    Voila!

    Sometimes it just isn't worth figuring out the "why"... :)

Topic Closed

This topic has been closed to new replies.

About this Topic