WordPress.org

Ready to get started?Download WordPress

Forums

how to change the default home page title (7 posts)

  1. piper007
    Member
    Posted 3 years ago #

    Hello

    I am using the frozen lotus template in my wordpress.

    There is a page called home. (It seems to be the default.) On the page it says hello world (at least I can change that). I don't the page called home, but I can't figure out how to change it. Anyone that looks at the front page sees this "home"

    oh yes in case you need to see my site: ilovemygarden.ca

    How can I change it to something better?

    Thanks for all your help

  2. AardvarkGirl
    Member
    Posted 3 years ago #

    Are using the 'posts' (blog) page as the 'home' page. Try going into your admin and checking out SETTINGS --> Reading --> 'Front Page Displays...'

    Do you want a 'page' as your default 'landing' or 'home' page? Then you'll need to create it, name it what ever you want, then try what I said above. :)

  3. piper007
    Member
    Posted 3 years ago #

    It's not working. I know how to change the front page settings and all, I did it with my other word press site, but there is still that tab called home. ( mygothcorner.com )

    I'm trying to change the tab name

    right now I have 2 pages across the top

    one is called gardening success stories and the other is called home.

    I'm trying to find a way to change the tab "home" to something else.

    Look at my page and you will see across the top the two pages.
    ilovemygarden.ca

    No matter what I do in the reading or writing section of my dashboard, that does not help me to change the word "home". I tried dozens of things with my other word press site and still have the tab "home"

    Every single wordpress theme comes with that first tab called home and then the title "hello world"

    I'm still looking through google for answers but no luck yet.

    Thanks

  4. AardvarkGirl
    Member
    Posted 3 years ago #

    Your 'home' page (ie where your domain name goes to) is your posts (blog) page, correct? So you don't want your initial 'landing page' (or your domain's home page) to show your posts, you want it to show static content, correct?

    When you first install WordPress the 'HOME' page is where the blog posts are being shown. "HELLO WORLD" is a sample blog post that comes with the WordPress install. You can delete that under POSTS in your admin area. But, in order to change the wording in the menu called HOME you'll have to re-assign where your blog posts are going (and thus name that new page) and then tell WordPress what you are going to have as the home page since you've moved the blog posts.

    In order to re-name that link (home) in your menu you have to create a NEW PAGE for your 'posts' - name it what ever you want ("Blog", "My Thoughts", etc). This page will not have static conent, it is merely used for your blog posts to show up on.

    You will then have to create a new page for your site to use as it's home page. "Home" is a very logical name for your website's home page, but again, you can name it what ever you want.

    After you've created these two NEW PAGES...
    go into the SETTINGS --> Reading --> 'Front Page Displays...' and on the radio buttons select A STATIC PAGE, then select the page you want as your website's home page. NEXT for your 'posts' page select the new page you created to show your blog posts.

    Of course save those changes.

  5. JarretC
    Member
    Posted 3 years ago #

    Log into your Dashboard and click on the Editor link under the Appearance menu on the left hand side.

    Then click on Main Index Template (index.php) on the right hand side of the Editor page. Look for the following line of code after clicking on index.php.

    <?php wp_list_pages('title_li=&depth=1'); ?>
    <li><a href="<?php bloginfo('home'); ?>/">Home</a></li>

    To change the Home tab as you mentioned modify the above code to something like

    <?php wp_list_pages('title_li=&depth=1'); ?>
    <li><a href="<?php bloginfo('home'); ?>/">New Tab Name</a></li>

    Once that is done, click on the blue Update file button and you should be all set.

    P.S. As a side note, I downloaded the theme and I noticed some encrypted code which inserts spam links into your website. While still in the Editor screen could you please visit Footer (footer.php) and copy/paste the code shown on this post?

    When posting the code make sure you click the code button above the textarea where you reply, paste the code that you see and then click the /code button again to close the tag so that it displays correctly.

  6. piper007
    Member
    Posted 3 years ago #

    ok. Thank you for the advice. Will work on it.

  7. metanoia unabashed
    Member
    Posted 2 years ago #

    Same problem here, but I don't find an editor button anywhere near Appearance; is that a custom blog feature?

    I tried to change the page title to Daily Mews in my Menu settings but to no avail. It held its new title on the Menu page, but remained Home on the blog.

    Any suggestions?

Topic Closed

This topic has been closed to new replies.

About this Topic