WordPress.org

Ready to get started?Download WordPress

Forums

how to change text within "Read More" buttons? (15 posts)

  1. Ronnie
    Member
    Posted 2 years ago #

    on my Courses page there are "Read More" buttons
    on my "Buy some Prints!" page there exists the same

    how can i maintain the "Read More" text on the Courses page buttons but have different text displayed on the "Buy some Prints!" page buttons?

    http://www.ronniewhittaker.com

  2. ahuggins
    Member
    Posted 2 years ago #

    If you have a custom archive template page you could set this in the archive page for your portfolio pieces from this: http://codex.wordpress.org/Customizing_the_Read_More

    For more on custom archive pages: http://codex.wordpress.org/Creating_an_Archive_Index

    hope that helps

  3. Ronnie
    Member
    Posted 2 years ago #

    thanks i'll give it a go this evening on return from the office

    btw i like your avatar logo, cool!

  4. Ronnie
    Member
    Posted 2 years ago #

    i've created an archives file and in that file i have placed "<?php the_content('TEST...'); ?>"

    then within wp-admin on my "Buy some Prints!" page i changed the template to archives

    it looks like this with no posts: http://www.ronniewhittaker.com/?page_id=689

    contents of archives.php:

    <?php
    /*
    Template Name: Archives
    */
    get_header(); ?>
    
    <div id="container">
    	<div id="content" role="main">
    
    		<?php the_post(); ?>
    		<h1 class="entry-title"><?php the_title(); ?></h1>
    
    		<?php get_search_form(); ?>
    
    	</div><!-- #content -->
    </div><!-- #container -->
    
    <?php the_content('TEST...'); ?>
    
    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

    where do i start please to resolve this?

  5. ahuggins
    Member
    Posted 2 years ago #

    I would have copied the code from the file you previously had been using, and then added/edited the content to be:
    <?php the_content('TEST...'); ?>

    It looks like you have not called the loop on this page. Which is why you are not seeing anything. Also, I am not sure how your site is set up, but you will need to change the query to look for the posts with the category/post_type bring in the prints. This is why I would have copied the old and made changes, since you already had it setup to get the content you wanted, then you really only need to change "readmore" tag in your the_content template tag, which is pretty easy to do. You then would still want to have the template name be: Archives or something, and change that for the page.

    Whatever Template your were using before, post that code here and I'll take a look.

  6. Ronnie
    Member
    Posted 2 years ago #

    thanks good info, well i've did that now and used a copy of the original page template. where to put the new content tag i don't know?

    there's one already in there - content()
    but when i edit this to read - content('TEST...')

    it makes no difference, the buttons on the page still remain as is with "Read more"

    what do you think.. and thanks so much for your time, appreciated

    [Code moderated as per the Forum Rules. Please use the pastebin]

  7. ahuggins
    Member
    Posted 2 years ago #

    Did you change your template on the page? Have to ask since you didn't say if you changed the template.

  8. Ronnie
    Member
    Posted 2 years ago #

    yes sorry i did... its now running with the archives.php template containing an exact copy of the code from the template previous

    http://pastebin.com/ucc4WRhn

  9. ahuggins
    Member
    Posted 2 years ago #

    I'm wondering what the contents of your portfolio_template.php file are. It looks like there is an if statement that might use that if this is categorized as a portfolio page, it could also be your contact_template.php, but I'm thinking portfolio_template.php.

    You could also try putting in something so you can see if it is the function or the file that is not working. Something like:

    <?php
    
    if ( have_posts() ) while ( have_posts() ) : the_post();
    
     ?>
    <h1>THIS IS WORKING</h1>
    
    <?php
    
            the_content('TEST...');

    Adding in something like that H1 tag, will show if that is actually getting loaded. If you try it and it doesn't show on the page, then it's probably because that if statement is loading one of those other templates.

    Let me know if that helps.

  10. Ronnie
    Member
    Posted 2 years ago #

    you're right it's in portfolio_template.php

    some code from it here: http://pastebin.com/yt6U5Hmb

    how would this be duplicated as i don't imagine i could simply create another template using this file? would i nee to hack this template code somehow? its well beyond me now

  11. ahuggins
    Member
    Posted 2 years ago #

    Hard to say what's really the best way to do this. You could copy the portfolio_template.php to say prints_template.php then since you are using a template that is only for your prints, you could then change the call for portfolio_template.php to prints_template.php. Then make any changes that are specific to your prints (like the "read more" more text to "Buy Now" (or something)) in the prints_template.php file.

    So basically, you used to have your OLD template, but you created a NEW template that currently has the exact same content as OLD template. They both currently include portfolio_template.php. So you copy the contents of portfolio_template.php to prints_template.php then change the NEW template to include prints_template.php and make your changes for what you want on your prints page in prints_template.php

    That should work...(I think). In theory it sounds right, but... Does that make sense to you?

  12. Ronnie
    Member
    Posted 2 years ago #

    it does, very much.. i've tried it and it looks perfect on the Prints page
    it has however knocked out the courses page, which is also a portfolio

    what i did was copied the 'onecolumn-page.php', which was the initial page template and created 'prints.php' as the new template which i assigned to the 'buy some prints' page

    i then copied the initial 'portfolio_template.php' and from it created "prints_template.php".

    then within 'prints.php' i changed the reference to 'onecolumn-page.php' to 'prints_template.php'

    is that what you meant by what you said?
    its quite straight forward but turns your head upside down! :-)

  13. Ronnie
    Member
    Posted 2 years ago #

    actually it works perfectly fine !!

    somehow i had blanked the contents of the original portfolio_template.php file of which the courses page relied

    thanks for your help i'm really pleased, most appreciated :-)

  14. ahuggins
    Member
    Posted 2 years ago #

    That's what I meant. Not sure why it caused problems on the courses page. hmm, nothing was changed in the one-column-page.php file, and the template for the page is the same, portfolio-template.php still exists?

  15. ahuggins
    Member
    Posted 2 years ago #

    Ah, glad you figured it out before I got my response in there. Awesome! Enjoy!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.