WordPress.org

Ready to get started?Download WordPress

Forums

How to change search button to my language? (9 posts)

  1. maxop
    Member
    Posted 2 years ago #

    Hello everyone,
    Ive just started with WP. This is My link:
    http://reality.fineart-photographer.com/?page_id=4
    I would like to know where and how I can change search button to my language. Since I dont know php what should I suppose to look for?
    Also how can I remove word "any" from search attributes?
    Thanks a lot

  2. neilfoster
    Member
    Posted 2 years ago #

    Appearance > Editor

    Look for and edit searchform.php and change the "value" from "Search" to "whatever".

    According to your theme as to whether you have a "searchform.php". You may find the search attributes here as well.

  3. maxop
    Member
    Posted 2 years ago #

    Thanks Neilfoster! Here is the thing: There is no "value" in searchform.php. I try to copy it here:

    <form method="get" id="searchform" action="<?php bloginfo('url'); ?>/">

    <label for="s"><?php _e('Search for:', 'kubrick'); ?></label>

    <div><input type="text" value="<?php the_search_query(); ?>" name="s" id="s" style="width: 95%;" />

    <button class="Button" type="submit" name="search">
    <span class="btn">
    <span class="t"><?php _e('Search', 'kubrick'); ?></span>
    <span class="r"><span></span></span>
    <span class="l"></span>
    </span>
    </button>
    </div>
    </form>

    Its "the_search_query" in the bracket? I am afraid that I ruin whole php, so please bear with me. I should overwrite like this:the_mylanguage_query ?
    I also have "Search result" search.php
    No "value" there. Thanks a lot

  4. neilfoster
    Member
    Posted 2 years ago #

    I've seen this exact searchform recently, now I can't find it to test...

    try changing this line: <span class="t"><?php _e('Search', 'kubrick'); ?></span>

    Change "Search" to your language.

    If that does not do it, add a value="Search" to
    <input type="text" value="<?php the_search_query(); ?>" name="s" id="s" style="width: 95%;" value="Search"/>

  5. neilfoster
    Member
    Posted 2 years ago #

    Found it. It's the first suggestion...

    <span class="t"><?php _e('Search', 'kubrick'); ?></span>

    Change the spelling here...

  6. maxop
    Member
    Posted 2 years ago #

    Well, I changed it, but still nothing. I did like this:
    <span class="t"><?php _e('MyLanguage', 'kubrick'); ?></span>

    Any other ideas what should I try? Thank you!

  7. neilfoster
    Member
    Posted 2 years ago #

    Strange. It works for me at http://upstairsroom.net/springs/

    Both themes are by LeadCamp and use the same searchform.php

    Are you using the "Search" button in a sidebar widget?

    If not then it might be hard-coded in the sidebar.php file. Check there.

    oh wait! That sidebar search is from somewhere else! I see it's part of the "widget" that lets you select type, cena do and obec. Is that a plugin? or some other widget that's coded into the theme?

  8. maxop
    Member
    Posted 2 years ago #

    ThatÅ› right. That widget is part of wp-proterty plugin I use.
    This is what plugin contains:

    wp-property/wp-property.php
    wp-property/js/jquery.ui.progressbar.js
    wp-property/js/jquery.scrollTo-min.js
    wp-property/js/jquery.ui.widget.min.js
    wp-property/js/jquery.ui.map.min.js
    wp-property/js/jquery.validate.js
    wp-property/js/fileuploader.js
    wp-property/js/wp-property-admin-overview.js
    wp-property/js/jquery.smookie.js
    wp-property/js/jquery.validate.min.js
    wp-property/js/wp-property-backend-global.js
    wp-property/js/jquery.ui.slider.min.js
    wp-property/js/jquery.number.format.js
    wp-property/js/jquery.address-1.3.2.js
    wp-property/js/wp-property-global.js
    wp-property/js/jquery.ui.mouse.min.js
    wp-property/templates/property-flyer.php
    wp-property/templates/property-overview.php
    wp-property/templates/template-functions.php
    wp-property/templates/property-map.php
    wp-property/templates/property-overview-plain_list.php
    wp-property/templates/property.php
    wp-property/templates/wp_properties.css
    wp-property/templates/wp_properties-ie_7.css
    wp-property/templates/wp_properties.js
    wp-property/templates/property-featured-shortcode.php
    wp-property/templates/wp_properties-msie.css
    wp-property/templates/property-overview-page.php
    wp-property/templates/pdf-list-template.php
    wp-property/templates/property-search-block.php
    wp-property/templates/property-search.php
    wp-property/legacy_support.php
    wp-property/readme.txt
    wp-property/core/class_rets.php
    wp-property/core/class_ud.php
    wp-property/core/class_core.php
    wp-property/core/class_functions.php
    wp-property/core/class_list_table.php
    wp-property/core/class_widgets.php
    wp-property/core/class_property_export.php
    wp-property/cron.php
    wp-property/third-party/jsmin.php
    wp-property/third-party/jquery.nivo.slider.pack.js
    wp-property/action_hooks.php
    wp-property/css/wp_properties_admin.css
    wp-property/css/jquery-ui.css
    wp-property/default_api.php

    Where do you thing it could be? Thanks

  9. gcahana
    Member
    Posted 2 years ago #

    It's in the wp-property/default_api.php.
    Just change the line no' 382 $attributes['fi'] = "Finnish";
    to your language and don't forget to clear cache and revalidate in the properties->settings->help section.
    One more thing don't upgrade the plugin it messes things in your language.
    You have to back it also with translation to your language in the
    wp-content/languages folder.
    Good luck....

Topic Closed

This topic has been closed to new replies.

About this Topic