WordPress.org

Ready to get started?Download WordPress

Forums

Misty Lake
[resolved] How to change post title and menu font (7 posts)

  1. foradoescritorio
    Member
    Posted 6 months ago #

    Hello,

    I'm trying to change the fonts of my menu bar and my post titles, but I can't seem to find how to. Could someone help me?
    The theme i'm using is Misty Lake.

    http://www.foradoescritorio.com.br

  2. foradoescritorio
    Member
    Posted 6 months ago #

    Thank you for no help.
    Already figured it out.

  3. Hi there, I'm glad you were able to figure it out!

    It looks like you've added some font files in a folder called fonts within your theme folder, and then added some Google font-face import statements directly to your style.css file:

    /* =Custom Fonts
    
    ----------------------------------------------- */
    
    @font-face {
    font-family: 'veneerregular';
    src: url('fonts/veneer-webfont.eot');
    src: url('fonts/veneer-webfont.eot?#iefix') format('embedded-opentype'),
    url('fonts/veneer-webfont.woff') format('woff'),
    url('fonts/veneer-webfont.ttf') format('truetype'),
    url('fonts/veneer-webfont.svg#veneerregular') format('svg');
    font-weight: normal;
    font-style: normal;
    }
    
    @font-face {
    font-family: 'travelingtypewriterregular';
    src: url('fonts/travelingtypewriter-webfont.eot');
    src: url('fonts/travelingtypewriter-webfont.eot?#iefix') format('embedded-opentype'),
    url('fonts/travelingtypewriter-webfont.woff') format('woff'),
    url('fonts/travelingtypewriter-webfont.tff') format('truetype'),
    url('fonts/travelingtypewriter-webfont.svg#travelingtypewriterregular') format('svg');
    font-weight: normal;
    font-style: normal;
    }
    
    @font-face {
    font-family: 'alicoscriptsskregular';
    src: url('fonts/alicoscriptssk-regular-webfont.eot');
    src: url('fonts/alicoscriptssk-regular-webfont.eot?#iefix') format('embedded-opentype'),
    url('fonts/alicoscriptssk-regular-webfont.woff') format('woff'),
    url('fonts/alicoscriptssk-regular-webfont.ttf') format('truetype'),
    url('fonts/alicoscriptssk-regular-webfont.svg#alicoscriptsskregular') format('svg');
    font-weight: normal;
    font-style: normal;
    }

    This means that the next time a new version of Misty Lake is released and you update it on your site, all your your changes will be overwritten unless you restore them from a backup.

    If you don't want to have to be concerned about this - which most folks don't - I'd recommend you create a child theme, and add your font folder and new CSS styles there.

    Making a child theme means your changes won't be overwritten when you update the theme. If you're new to child themes, you can explore these guides:

    http://codex.wordpress.org/Child_Themes
    http://op111.net/53/
    http://vimeo.com/49770088

    I really like your header graphic and background image. You might want to consider centering the background graphic of the wood planks so it looks a bit more balanced on larger screens.

    Here's what it looks like on my viewport at 1707px by 920px, for example: https://cloudup.com/cNTgzP1HvjU

    There's actually button to center the background graphic, under Appearance > Background:

    https://cloudup.com/cy9zAvDR6QI

    I also noticed your site has directory indexing on - you may want to turn that off for security reasons, otherwise anyone can see files in directories where there is no index file, like your fonts directory. Your host can usually provide documentation on how to do this.

    Good luck and happy theming!

  4. foradoescritorio
    Member
    Posted 6 months ago #

    Thank you for the complements and the help Kathryn.

    Would it be possible for you to explain to me how to change the directory indexing on bluehost? I figured, since wordpress and bluehost have a partnership, it could be possible that you know how to disable it.

    Best regards.

  5. Bluehost support is separate and should still be done at Bluehost, but they have a really great knowledge base that has answers to most everything about their hosting setup.

    Here's their help page about directory indexing:
    https://my.bluehost.com/cgi/help/114

    It says you can this line to your .htaccess file to stop directory indexes from showing:

    Options -Indexes

    Good luck!

  6. foradoescritorio
    Member
    Posted 6 months ago #

    Thank you Kathrynn,

    I belive that I did manage to change it through a wizard at bluehost.
    How can I be sure?

    I appreciate the help, And I would like to take the oportunity to also congratulate you for your website.
    It is pretty simple and intuitive, and keeps it's objective.

    Sincerely.

  7. Looks like you've turned off your directory indexing correctly, as I'm now seeing a "403 forbidden page" here, instead of the list of files I saw yesterday:

    http://www.foradoescritorio.com.br/wp-content/themes/misty-lake/fonts/

    I appreciate the help, And I would like to take the oportunity to also congratulate you for your website.
    It is pretty simple and intuitive, and keeps it's objective.

    You're very welcome, it was my pleasure. And thank you for the kind words about my site, I appreciate it!

Reply

You must log in to post.

About this Theme

About this Topic