WordPress.org

Ready to get started?Download WordPress

Forums

Facebook
[resolved] How to authenticate with Facebook? (7 posts)

  1. gryffyn
    Member
    Posted 1 year ago #

    I know this is something dumb, probably on my part, but I'm having trouble figuring it out so I'm reaching out to whoever might know.

    The goal is to be able to have WordPress auto-post to a specific Facebook page. I'm an admin on the page, I installed the Facebook addon in WordPress, I created a dummy page (which I'm obviously also an admin on), put in the dummy page app id and secret.

    Going to the Social Publisher page, I have a checkmark next to #1 (facebook application identifier associated with..), #2 says to create an Open Graphic action-object pair for "publish" and "article", which I did (no checkmark though.. but that's probably correct) but the third one (authenticate) has a red X next to it:

    Authenticate with Facebook to allow your Facebook application to post to your timeline or page on your behalf when a post is published. X

    Looking over the code and looking over forum posts, it sounds like I either connect via something in the login.php which is include()'d or possibly I put something in my user profile page. But I can't figure out how either works.

    Next to "Publish to page" it just says "Connect your Facebook account to get started", which is clickable, but only goes to href="#facebook-login" and does nothing. login.js looks like it handles some of that, but it's not being loaded on the social publishers page.

    Thanks in advance.

    http://wordpress.org/extend/plugins/facebook/

  2. relativist
    Member
    Posted 1 year ago #

    i have the same exact issue.

  3. relativist
    Member
    Posted 1 year ago #

    i also did a reinstall of the plugin with no solution

  4. gryffyn
    Member
    Posted 1 year ago #

    I gave up.. I saw that the Facebook-AWD extension was installed and was trying to use the same facebook ID. Didn't see how to "connect" using the Facebook one. I assumed since I was asked to get WordPress to post to a specific page that the Facebook-AWD addon wouldn't do it, but it will. So we're just using that.

  5. relativist
    Member
    Posted 1 year ago #

    i found an odd solution.
    i realized i had the "facebook disconnect" and "do not track" extensions installed on my chrome. so i disabled them, then installed facebook AWD. went through all of the steps to set up and authenticate. including connecting to FB on this plugin.

    then i disabled this Facebook AWD plugin and installed the Facebook WP plugin.
    and that little red X went away next to Authenticate. so now my Facebook WP plugin in working.

  6. gryffyn
    Member
    Posted 1 year ago #

    Yeah, it seemed that Facebook and Facebook-AWD both used the same user meta data variable to connect your WP user account to your FB account, but since Facebook-AWD "worked" and did what I wanted (post to specific FB pages), I didn't see the point in keeping two addons that did the same thing, but one worked fine all the way through.

    I need to see if that worked ok for the people using it. If not, I might give the Facebook addon another try I guess. Thanks for the tip, I thought that might work but didn't bother trying.

  7. thomas_grimault
    Member
    Posted 7 months ago #

    Hi, I took me almost all the afternoon, but I figured out what to do to get rid of that 'X' at the end of "Authenticate with Facebook to allow your Facebook application to post to your Timeline or Page on your behalf when a post is published":

    In wordpress admin, facebook -> social publisher, I missed the option "Publish to a page" at the very end of the page. Click on this, and "submit" when the Facebook page pops up. It enables everything for me ....

    It's too bad the 1, 2, 3, 4, 5 steps are so poorly explicit ... they could replace that "click on the link" directly ... it have save me 3 hours !

    Thomas

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic