WordPress.org

Ready to get started?Download WordPress

Forums

Members
How to allow Contributors to Edit their Authored PAGES using Members Plugin (5 posts)

  1. coachbrad
    Member
    Posted 5 months ago #

    I've just downloaded and activated Members so I can create a role so my coaches can access and edit pages that I've designated that they are the authors of.

    if I go into Roles and under Capabilities check
    edit_pages , will that allow them to access the pages that they are authors of while still restricting them from all the other pages?

    If not, how can I do this? My WP version is 3.7.1.

    Looks like a very useful plugin once I get familiar with it a little more.
    BRAD

    https://wordpress.org/plugins/members/

  2. groomedmonkey
    Member
    Posted 5 months ago #

    Yeah I am struggling with this too. I created a new role and assigned it all permissions yet I can't assign a user with that role to be an author of a page! Perhaps this is a bug?

  3. groomedmonkey
    Member
    Posted 5 months ago #

    The Capability Manager Enhanced plugin does work and will do what you want. I am setting it up for a school's website so that school admins can only edit specific pages that are assigned to them via authorship. I believe this is also what you want.

    Create a new role and allow Pages:Edit and Pages:Edit publish only. The Edit others capability is what allows a user to edit pages that they aren't the author of.

    Good luck! Hopefully Justin Tadlock will come across this and provide some insight into why the Members plugin doesn't work for this.

  4. coachbrad
    Member
    Posted 5 months ago #

    I did get this to work with Members. I assigned my coaches to be contributors then went into that Role and edited it checking the 'edit pages' box and saved. I had one of my coaches log in and confirm he could both see the page he was "Author" for as well as edit it. I know it's a little confusing 'author' vs. Contributor but that's how it worked for me.

  5. randallxski
    Member
    Posted 4 months ago #

    Thanks, coachbrad. Your explanation was very helpful. This worked for me as well. For my situation I edited the Contributor role and also added "edit published pages" and "publish pages" permissions. It's interesting that the Author cannot be selected when editing pages, but is only available in Quick Edit.

Reply

You must log in to post.

About this Plugin

About this Topic