WordPress.org

Ready to get started?Download WordPress

Forums

How to add feeds to feedburner (24 posts)

  1. jeruvy
    Member
    Posted 4 years ago #

    Hello.

    I have been looking at a solution to this question for many weeks and suffice I have read a lot of material, I have not been able to find a working solution.

    I have a couple wordpress sites that I'm running and very happy with the packages and the capabilities. However I'm still learning my way around the ropes so to speak.

    I cannot figure out however how to add my RSS feeds to feedburner. I've followed the documentation on feedburner.com (google) to add steve smiths plugin but this does not seem to work with the latest version of wordpress. I've tried a couple others but they seemed to not work either. So I'm open to trying all over again from scratch if someone has a working 'how to' for the latest version of WordPress.

    Another related issue is if I click on the link for RSS feeds on one of my sites, say http://www.example.com/feed/, I get a 'google' page to either add it to my home page or to Google Reader, which seems normal enough to me. But when I add it to Google Reader instead of picking up the latest stories it only picks up the first two (really old) and does not update.

    Perhaps learning how to get feedburner to work will solve this problem but I'm hopeful to get some answers from experts who've mastered this step.

    Cheers.

  2. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    so...you just want your rss feed in feedburner? Or are you looking for some other functionality?

    To add afeed to feedburner, you just log in and type the feed like you have above into feedburner. Then it picks up your rss feed....

  3. jeruvy
    Member
    Posted 4 years ago #

    Does not work. 404 error.

  4. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    hmm....I'm not too good with this stuff, but I've had permalinks, and plugins affect my feeds before....

    does http://www.example.com/?feed=rss
    work any better?

  5. jeruvy
    Member
    Posted 4 years ago #

    Nope, same error.

  6. france1972
    Member
    Posted 4 years ago #

    Maybe is this one? this redirects WordPress feeds to Feedburner

    try this also:
    # Redirect Feeds to Feedburner
    RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /(feed|wp-atom|wp-feed|wp-rss|wp-rdf|wp-commentsrss)(.+)\ HTTP/ [NC,OR]
    RewriteCond %{QUERY_STRING} ^feed [NC]
    RewriteCond %{HTTP_USER_AGENT} !^(FeedBurner|FeedValidator) [NC]
    RewriteRule .* http://feeds2.feedburner.com/yourwebsite? [R=307,L]
    RewriteRule ^comments/?.*$ http://feeds2.feedburner.com/yourcomments [L,R=302]

  7. jeruvy
    Member
    Posted 4 years ago #

    Thanks, but does anyone know anything that 'actually works'? I've tried these already, like I said I've spent a LOT of time getting this to work, and I'm a bit surprised it's not clearer.

    So for giggles I (re)added this, but nothing has changed. I still get stale old feed data to either google homepage or google reader. Feedburner still 404's.

    "Sorry -- This feed does not validate ** Server returned HTTP Error 404:Not Found"

  8. Step back. Let's start from the basics :)

    Turn off the plugin and remove any related htaccess code and check the following:
    1) Does your feed validate without FeedBurner?
    2) Does the FeedBurner feed validate on it's own?

    Independent of the plugin or htaccess rules (which is what I use, personally), those two things should work. If they don't, therein lies your problem.

    It might help if you toss up the links for these feeds, so we can take a look and maybe see something you're missing :)

  9. jeruvy
    Member
    Posted 4 years ago #

    Thanks. At the moment I have no feed related plugins installed. So I'm strickly using the default (whatever) with the WP package.

    Commenting out the above rewrite code, the above errors as described already are the situation. But let me answer your pointed questions:

    1) Feedvalidator.org reports this error regardless:
    "Sorry -- This feed does not validate ** Server returned HTTP Error 404:Not Found"
    2) What feedburner feed? I still haven't added my feeds to feedburner (what I'm trying to accomplish)
    "An error occurred connecting to the URL: Error getting URL: 404 - Not Found"

    So forgive my ignorance, but since 'therein lies my problem' could you elaborate for me?

    The feed in question is for http://jamesfriesen.net

    I've tried: http://jamesfriesen.net, jamesfriesen.net/rss, jamesfriesen.net/?feed=rss most recently.

    I've also tried passing the php files in the root folder; wp-atom.php, wp-commentsrss2.php, wp-feed.php to no avail.

  10. Actually, that did explain to me what's wrong. The problem has jack to do with FeedBurner, so let's leave this out of the equation for the nonce :)

    Your feed SHOULD be http://jamesfriesen.net/feed but that isn't working, as it comes up empty. If we fix that, then you can go make a FeedBurner feed (which by the way means you have to register at feedburner.com and 'create' a feed there, which will import that busted feed). I get ahead of things. Let's fix your feed!

    Go to http://jamesfriesen.net/wp-admin/options-reading.php and make sure that Syndication feeds show the most recent isn't set to 0 or something silly like that.

    Then, temporarily turn off permalinks and view your page regularly. If you view the page source in your browser, you should get a line like this:

    <link rel="alternate" type="application/rss+xml" title="James Friesen's Tech Blog RSS Feed" href="http://jamesfriesen.net/feed" />

    That's your feed link, check THAT and see if it works.

    If not, we'll keep trying other things (like deleting your .htaccess file and making a new one).

    I'm 99.999% sure it's .htaccess/permalinks, though.

  11. jeruvy
    Member
    Posted 4 years ago #

    Ok, going to options-reading.php I see that syndication feeds show the most recent is set to '2'. Of course it's actually showing the 'least recent'.

    Going to options-permalink.php I changed common settings to 'Default' as I assume this is what you are asking me to do to turn off permalinks. One of the plugins generated a Mysql error, but reloading the page, seemed to show the change has taken affect.

    Now if I click on the RSS feed link at the top, I get a really bad error. And the redirect is no longer working!!

    I do see an <link> entry as above, but its showing the apostrophe as "& # 0 3 9 ;" and not ', I'm wondering if this is a problem?

    The feed link is the same, but now appears broken (and the error page is broken too).

  12. jeruvy
    Member
    Posted 4 years ago #

    Ok, fixed the error handler, sort of. It's now verifying its a 404 error.

  13. jeruvy
    Member
    Posted 4 years ago #

    Since this gave me something to work on, I attempted to check the "XHTML 1.0 transitional" as suggested by this site: http://samdevol.com/wordpress-troubleshooting-i-have-to-validate-oh-my/

    Of course I found that there were errors. 242 to be precise.

    This is a bit overwhelming, and I'm wondering how to go about debugging this? How do I know which is (theme/plugin/base) to blame?

  14. jeruvy
    Member
    Posted 4 years ago #

    I see this isn't as easy as everyone makes it out to be. Any more suggestions?

  15. Sorry, family showed up. I suspect this is a bad support week :)

    Don't worry about the formatting of the apostrophe. Also, the validity of your HTML shouldn't matter just yet either.

    Turn Permalinks back on to the custom you had before, and can you tell us what's in the .htaccess file?

  16. jeruvy
    Member
    Posted 4 years ago #

    Sure, tis the season ;) Thanks I'll ignore the apostrophe.

    Whats in the .htaccess file? Just some errordocument entries and some ip bans. thats it at the moment, the above I've removed.

  17. At the very least you should have this for WP to run:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
  18. jeruvy
    Member
    Posted 4 years ago #

    Hmm, yes 'if' permalinks are enabled/used. Otherwise it seems happy without this.

    Was there some other point to this step?

  19. Your theme is pointing to /feed as the RSS source, so at some point it thinks/wants you to have permalinks.

    Other than that, something in your htaccess file is conflicting. I'd remove it, see if it works, and if not, just start with the generic. Add things in one step at a time until it breaks again.

    The other (common) reason this happens is a conflicting plugin.

    (Just returned from days in the wild woolly granny's where 'Internet' is rare)

  20. pompapah
    Member
    Posted 3 years ago #

    I've tried the generic template and am still getting a 404
    all plugins deactivated and still a 404

    GoDaddy says everything is fine

  21. jascanio
    Member
    Posted 3 years ago #

    I am having the EXACT same issue with my RSS feed. Any luck yet?

  22. kathecasta
    Member
    Posted 3 years ago #

    same exact issue here too! it happens to me whether i'm using a custom permalink or the default link. i've tried deactivating some plugins and activating them again, but the issue isn't going away! HELP!

  23. kathecasta
    Member
    Posted 3 years ago #

    actually i just checked on feedburner and it asked me to see if my feed was valid and to confirm its validity. i clicked and it took me to this page:
    http://feedvalidator.org/check.cgi?url=http://www.blog.studioearchitects.com/feed/
    and it says that my feed isn't valid....some sort of date/time issue. but i checked in my settings and i'm using one of the default date/time.

  24. ChickiChicki
    Member
    Posted 3 years ago #

    kathecasta, I notice that your feed is now valid. I've been having the same problem with mine at http://beau-tan.com/feed/. What did you do to get your feed to validate? Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic