WordPress.org

Ready to get started?Download WordPress

Forums

How to add bank paragraphs to posts? (6 posts)

  1. shidouhikari
    Member
    Posted 6 years ago #

    Hello. My texts are getting too "heavy" because they are too much "compressed". I'd like to clean they a bit adding blank lines/paraphs between one paragraph and another one.

    But on edit page, if I press ENTER a few times, when the text is saved all new paragraphs are deleted, and each paragraph is placed just below its adjacent.

    I'd like to use things like "

    " or
    "<p> </p>
    <p> </p>".

    Is there any config or even plugin that allows it?

  2. Chris_K
    Member
    Posted 6 years ago #

    Why not just edit your theme's style sheet to add a bit of margin to the content's <p> tag?

  3. shidouhikari
    Member
    Posted 6 years ago #

    Hello, sorry for taking so long to reply.

    I added p {margin: 2em 0;} to style.css and now there is a little space between one paragraph and another, but I'm still unable to add empty paragraphs on text.

    Stuff like <p> </p>,
    ,
    ,
    doesn't work, and after editing they are gone and empty paragraphs are erased. I tried on Visual and Code panels, and nothing seems to work.

    Do you know how to do it? :)

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    You cannot add empty paragraphs. WordPress intentionally removes such things because they are non-semantic.

    If you want to add more vertical spacing, then do so directly with something like:
    <p style="margin-bottom:4em;">This paragraph has extra space at the end of it.</p>
    Remember, your content is not just for your webpage. It can also appear on feeds, as text on other sites, etc. Trying to hit enter to add spacing doesn't work everywhere, and is uncertain at best. How much vertical space is "one empty paragraph", anyway? No way to tell.

  5. shidouhikari
    Member
    Posted 6 years ago #

    tnx for the tip, I also found out that using "<!--empty paragraph-->" creates an empty space on text :)

  6. shidouhikari
    Member
    Posted 6 years ago #

    Sorry for returning on this issue, but it is not solved yet :p

    Creating empty paragraphs worked at first, but if I try to edit a post they are removed by wordpress editor.

    I tried to create a text on Dreamweaver and copied its HTML directly to post code editor, and it worked, even more than one empty paragraph is shown, only "
    " doesn't work.

    But once I try to edit the post, all empty paragraphs are removed.

    So, is there a way to disable it, and wordpress's editor stops automatically editing HTML code? I'd like to just copy it and paste on dreamweaver. Anyway I'm not good on HTML and dreamweaver has lots more features :)
    ATM I'm doing it copying directly from database with phpmyadmin, but I'd like not to access database directly.

Topic Closed

This topic has been closed to new replies.

About this Topic