WordPress.org

Ready to get started?Download WordPress

Forums

How to add an image to the footer of each post? (9 posts)

  1. Tee
    Member
    Posted 5 years ago #

    Hey Folks.

    Have a look here: http://www.PUMATALK.com/blog and what I would like to do is, to place an image above the "feed icons" at the bottom of each post, there the text is; "Help to spread the word - Share it & Enjoy it. Thank you!"

    Can anyone help me out please.
    -Joey

  2. stvwlf
    Member
    Posted 5 years ago #

    Without seeing your index.php code can't tell you the exact line

    In the default WP theme it would go here in index.php (see below)

    <div class="entry">
           <?php the_content('Read the rest of this entry &raquo;'); ?>
        </div>
    
       <p class="postmetadata"><?php the_tags('Tags: ', ', ', '<br />'); ?> Posted in <?php the_category(', ') ?> | <?php edit_post_link('Edit', '', ' | '); ?>  <?php comments_popup_link('No Comments »', '1 Comment »', '% Comments »'); ?></p>
    
    =====>  insert here 
    
    </div><!-- end of id="content"-->
    <?php endwhile; ?>
  3. Shane G
    Member
    Posted 5 years ago #

    Hi,

    I think you need to use Gravatar for your post..for that please refer:

    [spam link moderated]

  4. Tee
    Member
    Posted 5 years ago #

    Hey Folks.

    1. Here's what i got: http://yoast.com/wordpress/sociable/

    2. And what I want to do is on the bottom of each post above the sociable icons to to have a message that says: http://i39.tinypic.com/andgy0.jpg

    3. Here's how it currently looks like: http://i43.tinypic.com/27xf85u.png

    The only problem is to point #2 is, that text is defined in the settings in the admin panel in WP.

    So what should i do?
    Please help.
    Thanks.
    -JOey

  5. Tee
    Member
    Posted 5 years ago #

    Hi Stv.

    Check out - I did what you suggested, it worked - but what I want to do it have it above the sociable "sharable" icons:

    Here's a screenshot: http://i43.tinypic.com/wjawr8.png

    Thanks.
    -JOey

  6. stvwlf
    Member
    Posted 5 years ago #

    Hi

    Move the code you inserted to just below your PumaTalk image, the one that has the filename of 2vmizae.png - just below that.

    I've used the Sociable plugin before - I seem to remember there is a way that you can paste some activating code into the page instead of it auto-placing itself. So if inserting it where I suggested you move it to doesn't work, read the read-me instructions with Sociable. I think it explains how to set it up manually. That would be your next step if below PumaTalk doesn't do it for you.

  7. Tee
    Member
    Posted 5 years ago #

    Hey Stv.

    The filename: 2vmizae.png - i manually insert that in very post that I make that I want to connect the discussion back to the forum, so it shouldn't be on the footer of every page.

    Can you have a look at the icons and click them and let me know if;

    1. which images break (do not show) for me I can't see myspace & digg
    2. which links aren't accurate.

    Here's a screenshot: http://i40.tinypic.com/z2ttt.png

    Please & thanks.
    -Joey

  8. stvwlf
    Member
    Posted 5 years ago #

    Hi

    This is from the Sociable plugin website
    http://yoast.com/wordpress/sociable/

    Changing the location of the icons
    Instead of attaching the buttons to the end of the post, you can also choose to work them into your template. You can do that simply by adding the following code anywhere you'd like the buttons to appear:

    <?php if (function_exists('sociable_html')) {
    echo sociable_html();
    } ?>

    You can also choose to show only a selected group of sites:

    <?php if (function_exists('sociable_html')) {
    echo sociable_html(Array("Reddit", "del.icio.us"));
    } ?>

    This will show these sites only when they are activated in Sociable's settings. If you're using this, be sure to disable any automatic additions to the content in the Sociable admin panel.

    So use that code, put it in your template after the code I sent you yesterday. That gives you control over where the icons appear. Turn off "automatic additions to content" in the sociable admin panel.

    =========
    Images: the img src to MySpace and Digg are
    http://www.pumatalk.com/blog/wp-content/plugins/sociable/images/
    They are missing the image filename at the end of the URL

    The image for del.icio.us is 520 pixels long and consists of the URL to the image, as a graphic - the words, no visual.
    http://www.pumatalk.com/blog/wp-content/plugins/sociable/images/delicious.jpg - take a look at that URL

    You need a replacement image for delicious.jpg, or else you are using the wrong filename. I believe you can configure this stuff in the sociable plugin control page

  9. Tee
    Member
    Posted 5 years ago #

    Hey Stv.

    Thanks a lot for the help mate! It's fixed - I deciced just to fix the broken icons and keep everything the way it is :)

    Thanks again.
    -Joey

Topic Closed

This topic has been closed to new replies.

About this Topic