WordPress.org

Ready to get started?Download WordPress

Forums

How to Add a Blog to an Existing Website? (12 posts)

  1. cfrazier77
    Member
    Posted 5 years ago #

    I have recently uploaded and installed the files and I have changed the index.php file to blog.php in hopes of adding the blog to my existing site at http://www.theyeastdiet.com/blog.php however the comments and preview pages all link back to the main index page of my site instead of the blog page...I need some help knowing what file to modify to accomplish a track back to the blog site for all the comments etc....

    Thanks in advance.

  2. moshu
    Member
    Posted 5 years ago #

    You can not change the index file's name into anything else.

    If you want your blog at example.com/blog - install it in a subfolder named "blog" on your site.

  3. cfrazier77
    Member
    Posted 5 years ago #

    ok- I have installed it in the subfolder and uploaded the folder...anything else I need to do? Somehow it is still not showing the way I want it to....thanks for the help.

  4. moshu
    Member
    Posted 5 years ago #

    You deleted the old install first, did you?
    Now you have quite a mess there:
    http://www.theyeastdiet.com/blog.php/ - that should be removed!
    http://www.theyeastdiet.com/?cat=3 - this when things go wrong...
    http://www.theyeastdiet.com/blog/ - and this is where your new install failed

  5. cfrazier77
    Member
    Posted 5 years ago #

    I have deleted the blog.php file and saved the index.php file to a blog folder on the root directory. I have all the other WP php files saved under the main directory along with my website files. Now you can see where the blog fails at http://www.theyeastdiet.com/blog/ any idea what could be wrong?

    Thanks.

  6. moshu
    Member
    Posted 5 years ago #

    index.php file to a blog folder on the root directory. I have all the other WP php files saved under the main directory

    That's exactly your problem: index in one place and the rest in another place.
    They must be in the same place - everything in the /blog/ folder!

  7. cfrazier77
    Member
    Posted 5 years ago #

    Got it- it is very close now however the formatting is gone...do I need to clear the database tables and then reinstall? If so how do I do that? I use 1and1 hosting fyi. Thanks.

    http://www.theyeastdiet.com/blog/

  8. moshu
    Member
    Posted 5 years ago #

    No, no. Don't go to that newbie obsession that reinstalling would solve everything, or anything.

    If you can login just change the two URL values in admin > Setting > General.

  9. cfrazier77
    Member
    Posted 5 years ago #

    That's just it- it won't let me login- I can get to the login screen, but it takes me to the error page after clicking login.

  10. cfrazier77
    Member
    Posted 5 years ago #

    Can I edit these URL values from the php files themselves?

  11. moshu
    Member
    Posted 5 years ago #

    They are not in files... there is nothing in files, everything is in the database, including the wrong URLs.

    Here is the fix:
    http://www.tamba2.org.uk/wordpress/site-url/
    I hope you have access to your database!

  12. cfrazier77
    Member
    Posted 5 years ago #

    GENIUS!!! I have made the changes and everything seems in order with my address. I am also able to login to my account....thank you, thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic