WordPress.org

Ready to get started?Download WordPress

Forums

How remove comments & how create index for each blog entry? (7 posts)

  1. netvicar
    Member
    Posted 9 years ago #

    Forgive me if I sound like I'm new to blogging, because I am :-)

    If you can help thanks a bunch!

    I have two "simple" questions.

    1) How do i remove "comments" option from showing up next to my blog entries?

    I've already figured how to make each comment moderator approved, but that's not what I want.

    I want to eliminate comments altogether because spammers are trying multiple attempts to post daily and these are filling my mailbox with unnecessary 'approve delete' messages.

    So I want no commenting allowed at all. Not even moderator approved.

    Is there a php line in the index.php I can delete or is this disabled in some other template?

    I see this person has similar question but not yet have answer as of yet: http://wordpress.org/support/topic.php?id=21279

    2) Is there a way to create an index page of topics/links for each blog entry so people can easier select which entry they want to read instead of having to scroll the whole page (as on my blog at http://www.economicbooster.com/blog)?

    Something simple similar to http://wordpress.org/support/forum.php?id=3 but only with the topic column (not the posts, last poster, freshness, etc columns).

    I'm thinking I may have set something up incorrectly and that is why I only see a long page with all entries instead of an index page with links to each entry(?).

    Or maybe I'm just looking at the wrong page(?)

    3) I lied. I have one final question I just remembered :-)

    This one is NOT important because I can just as well avoid using permalinks unless critical to #1 or #2 above.

    When I select the permalink option and create a ../blog/.htaccess file with the stuff wp says to add to .htaccess I get internal server errors and blog is non-functional.

    Is there some header info that needs to be in the htaccess file along with the stuff wp says to add? Or what else might be the problem (besides newbie being over his head).

    Thanks much for your help.

    Andre
    ps: I'm using WordPress 1.2.1

  2. ryoken
    Member
    Posted 9 years ago #

    first off, upgrade to 1.2.2

    1) i assume you've turned off comments in your wordpress options. now you'll need to make the following edits to your index.php.find these two lines:

    <?php comments_popup_link(__("Comments (0)"), __("Comments (1)"), __("Comments (%)")); ?>

    and

    <?php include(ABSPATH . "wp-comments.php"); ?>

    insert // after each <?php to comment those out.

    i haven't tried this myself so if anything breaks just revert.

    2) look into http://wordpress.org/support/topic.php?id=6041 this wouldn't be your index, but it would be an easy way to go through archives and find the post you want.

    3) there are plenty of issues. just search.

  3. netvicar
    Member
    Posted 9 years ago #

    Thanks a bunch ryoken!

    I upgraded to version 1.22 without a hitch and made the changes above as suggested

    Also made the changes to remove comments. Also went smoothly. Nothing seems broken because everything is working fine. I think blog looks better without that comments field hanging after every message. My opinion though...

    I will search more on how to create an index of my archives later (so people can pick and choose which posts they want to read without scrolling the whole page because my blog is gonna get huge).

    I'll fix the htaccess problem later. I think it may be a permission issue but not yet sure. I'll know once i scroll through my server logs for errors //yuck//

    Thanks again for the help.

    Andre

    fyi for anyone who's following this thread. index.php in v 1.2.1 is a little different than example above. So if you are doing a cut and paste 'find' then look for these:

    comments_popup_link(__('Comments (0)'), __('Comments (1)'), __('Comments (%)'));

    include(ABSPATH . 'wp-comments.php');

  4. netvicar
    Member
    Posted 9 years ago #

    Stinkin' blog spammers!!!!

    They've added an unnecessary extra daily administration headache for me.

    I removed comments from index.php so that comments are not available from a web browser. However, the comments option still appears as an action when reading the feed with an rss client.

    That's how spammers are still sending comments (that get trapped in blog admin approval) to my blog.

    How do I remove the comments options completely so rss clients can't see comments option and so i don't have to have daily administration headaches of having to manually delete these porn and casino spam messages?

    Thanks!

    Andre
    p.s. I hope what i said was clear(?). If not please ask. Thank in advance!!!

  5. netvicar
    Member
    Posted 9 years ago #

    Ok, reading through the threads on spam and spamassassin and spamkitty I guess what I want is to disable all comments so no one can even try posting spam, and disable moderation so i don't have to read their dirty messages either (if that is possible).

    Thanks

  6. Just delete the wp-comments-post.php file.

  7. netvicar
    Member
    Posted 9 years ago #

    Thanks, narchives.php was exactly what I was looking for for creating an index.

    bye

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.