WordPress.org

Ready to get started?Download WordPress

Forums

How fix black diamond question marks in WP 3.2.1? (13 posts)

  1. misty9
    Member
    Posted 2 years ago #

    To display multi-byte characters (i.e Japanese, Korean and etc) in WordPress, I've done the required steps below and the mult-byte characters are displayed properly.

    However, the dashes, quotes, apostrophes and etc have turned into black diamond question marks on the pages.

    1. Commenting out these two lines in wp-config.php

    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    2. The "latin1_swedish_ci" is replaced with "utf8_general_ci" the Collation field for every table in the database.

    3. Settings -> Reading -> Encoding is set to UTF-8

    Besides the above three steps, what else should I change to fix the question marks? Thanks.

  2. misty9
    Member
    Posted 2 years ago #

    The above three steps used to work for previous WP versions.

    uh, I've just found something odd with WordPress 3.2.1, after updating the Collation field for a given table, the Collation fields for the relevant rows are NOT updated with intended changes.

    In other words, the Collation for all rows of wp_posts remain as "latin1_swedish_ci" instead of "utf8_general_ci".

    This maybe a bug and will ask the developers for a confirmation...

  3. misty9
    Member
    Posted 2 years ago #

    I've filed a little bug and hopefully they can shed some light on this.

    http://core.trac.wordpress.org/ticket/19506

  4. kellio
    Member
    Posted 2 years ago #

    I've been experiencing the same thing where spaces and apostophies are turning into the triangular question marks after publishing or editing posts. � Just like that!

  5. pisosse
    Member
    Posted 2 years ago #

    Any news to this as I have the same problem and whent through a reinstallation and collation change on everything on my mamp database?

  6. aliceralph
    Member
    Posted 2 years ago #

    Help! Anyone got a fix yet?

    I am using 3.3.1 and still have same problem. Grr!

  7. kellio
    Member
    Posted 2 years ago #

    I don't know what happened but the problem is no longer occurring on my sites.

    I edited all the triangles out manually and since then have not had a problem with it.

  8. wilfil
    Member
    Posted 2 years ago #

    This must be some kind of bug as I have experienced it too. Unfortunately my site is too large to manually edit them out.

  9. kellio
    Member
    Posted 2 years ago #

    I think I can be 99% sure it's a plugin that's causing the error. It was only happening on sites on which I had exactly the same plugins installed.
    I've since set up other sites with different plugins and no longer have the problem.
    I never got around to finding which plugin was doing it, but I suspect it's a caching plugin so you might try disabling any you have installed to see if it rectifies the problem.

  10. shirazdrum
    Member
    Posted 2 years ago #

    This is the result of saving your files in non UTF-8 format such as ANSI. When you open a file with text editors that don't support UTF-8 and save it again, this will happen.

    Download a text editor such as Notepad++ and check and convert all your (plugin or theme) files to UTF-8 or UTF-8 Without BOM and you should be Ok.

  11. aliceralph
    Member
    Posted 2 years ago #

    I am still having this problem but I am sure it is server related. It happens on my hosted sites, but not on my localhost (MAMP) - even with the exact same database/files. Also I can copy and paste the same text from the same document into my localhost no problem, but files on my hosted server it adds the diamonds. So frustrating!

    kellio, thanks for your suggestion but unfortunately it even happens on an out-of-the-box installation of WordPress with no plugins installed/activated.

    Anybody know if this could be caused by a particular server setting? I have checked and can't see any glaring differences but it seems this can be the only potential source of a variable causing this. I have uploaded the same files to other servers/hosts and not had that problem - so surely something to do with my hosting? No idea what it could be though. Any thoughts?

  12. shirazdrum
    Member
    Posted 2 years ago #

    @aliceralph

    The character encoding is not set at the server level or it's not properly declared through the HTML meta element (and/or the XML declaration for XHTML documents)

    Without seeing your site or the files, no way to say which one is the case.

  13. aliceralph
    Member
    Posted 2 years ago #

    Hi again everyone. Okay after a lot of digging, we finally worked this one out...

    Our problem was that either we had the black diamonds, or if we amended the UTF or wp-config file then sometimes it was completely stripping out everything after a special character. Eventually my colleague found this post...

    http://wordpress.org/support/topic/pound-sign-causing-content-curtailment

    "If your PHP settings have 'Multibyte String : mbstring.encoding_translation' turned on, some special characters will not display, and cutail any content follwoing them."

    This seems to have done the trick. Hope it helps somebody else.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.