WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] (how) does my WordPress automatically make redirects? (6 posts)

  1. Thomas040ehv
    Member
    Posted 9 months ago #

    A client of mine was hit by Penguin, since he had bought links from India in the past. I decided to remove the pages that had the ugliest link profiles, and put the content online on different urls. This way, the bad links would not lead to real pages, just to 404's.

    My whole plan doesn't seem possible, because somehow WordPress automacally makes 301 redirects from the previous url to the new url. Could this be because the urls are similar? It happens in all different browsers and also on different pc's and IP's.

    Note: I didn't change the url, i really put the bad pages on no-index with Yoast and then even trashed them. Then, I rewrote the content that were on these bad pages and made new pages for it.

    Does anyone have an idea on what could cause this redirection to happen?
    I checked all plugins and all possible WordPress settings, but can't find the solution anywhere.

  2. WPWhiteSecurity
    Member
    Posted 9 months ago #

    Hi,

    You can override WordPress redirects in an htaccess. Here is more information about htaccess and redirects in Apache:

    http://httpd.apache.org/docs/2.2/mod/mod_alias.html#redirect

  3. My whole plan doesn't seem possible, because somehow WordPress automacally makes 301 redirects from the previous url to the new url.

    That's the canonical redirection feature and that's the idea: get visitors to the correct (new) URL.

    While I personally think it's a great feature (you do want to keep visitors right?) that is something you can disable via a plugin.

    http://wordpress.org/plugins/search.php?q=disable+canonical

  4. Thomas040ehv
    Member
    Posted 9 months ago #

    Thank you Jan.

    I do want to keep visitors, but most visitors come in through the homepage. Luckily, the link profile of the home is not bad. The bought links were all to deeper pages on the website. They were meant only for linkjuice, not for real visitors. Most of these links are actually from English websites, but my clients site is in Dutch.

  5. Thomas040ehv
    Member
    Posted 9 months ago #

    Thanks everyone. It is fixed by using the plugin Fix Multiple Redirects 1.2 and then checking the box for 'Template Redirect filters to disable' 'Redirect canonical'.

  6. Thomas040ehv
    Member
    Posted 8 months ago #

    I actually think it is a Yoast SEO plugin thing... But I'm still not sure.

    My reply when I thought it was fixed was a bit too early. The solution I had 3 weeks ago f*cked up some other parts of the site.
    I know fixed it by manually redirecting the 'bad' urls to /404.

    Not the best solution, but okay I guess.

Reply

You must log in to post.

About this Topic

Tags