WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How do you set Featured Image in latest WP dashboard? (13 posts)

  1. G-Olly
    Member
    Posted 2 years ago #

    Hi There,

    In previous versions when uploading images via the browser uploader, the dialogue box used to have a set as featured image button. I cannot seem to find this in the new dashboard, is there a different process involved now? And if so, what is it?

    Many thanks,
    Olly

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    It's still there. Either at the bottom of the details for each image when you use Add Media. Or via the Edit Post/Edit page interfaces (lower right-hand column).

  3. G-Olly
    Member
    Posted 2 years ago #

    Sorry, I'm probably being very stupid, but I do not see it anywhere. Please see here: dashboard image upload pic

    Please can you indicate via a diagram or something?

    Many thanks again.

    [No bumping. If it's that urgent, consider hiring someone.]

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  5. G-Olly
    Member
    Posted 2 years ago #

    Thanks for the advice Esmi, I will let you know how it goes.

  6. deepbevel
    Member
    Posted 2 years ago #

    I'm wondering if the featured image widget is still available in the post editor, or if having it selected/not selected under screen options (at the top of the post editor) has anything to do with it?

  7. esmi
    Forum Moderator
    Posted 2 years ago #

    Featured images are supported at a theme - not a core - level. So the first step would be to switch to a theme that we know does support featured images. :-)

  8. deepbevel
    Member
    Posted 2 years ago #

    yes, and not to challange the expertise of the theme diva, but I just tried disabling featured images in the screen options, and now the link no longer appears in the media uploader either. It would be easy enough to try?

  9. G-Olly
    Member
    Posted 2 years ago #

    Hi Guys,

    Esmi you were right it is because of the theme I am using. I swapped over to Twenty Eleven and there was the use as featured image button. The theme I am using is Piano Black. Is there a simple way of getting the theme to display this option or will it mean I have to change it?

  10. G-Olly
    Member
    Posted 2 years ago #

    I should say, as this option was previously available in wordpress 3.2 with this theme.

  11. keesiemeijer
    moderator
    Posted 2 years ago #

    read: http://codex.wordpress.org/Post_Thumbnails

    Themes have to add support for post thumbnails in functions.php:

    if ( function_exists( 'add_theme_support' ) ) {
      add_theme_support( 'post-thumbnails' );
    }

    http://codex.wordpress.org/Function_Reference/add_theme_support

  12. G-Olly
    Member
    Posted 2 years ago #

    Thanks keesiemeijer, I'll give that a go and let you know.

  13. G-Olly
    Member
    Posted 2 years ago #

    Hi Keesiemeijer, that has worked perfectly, the use as featured image is back in place. Thank you all for your help, it is much appreciated.

Topic Closed

This topic has been closed to new replies.

About this Topic