WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How do you change the image upload directory in 3.4.2? (9 posts)

  1. DebbieInTX
    Member
    Posted 1 year ago #

    I want to change my image upload directory to be just (website)/media without year/month/day subdirectories. I found a forum post that seems to have the answer:

    "I checked the path to upload the images in uploads folder in setting->media->Store uploads in this folder, and make the textbox blank to allow images to upload defaultly in upload folders."

    However, I don't see any option like that in my Settings -> Media. Did it move?

  2. Andrew Bartel
    Member
    Posted 1 year ago #

    Nope still there, under the heading "Uploading Files"

  3. DebbieInTX
    Member
    Posted 1 year ago #

    Am I looking in the right place? I just don't see it. Here's a screen shot.

  4. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    You are in the correct spot but you are missing the uploading files part.
    http://codex.wordpress.org/Settings_Media_Screen

    You may be running a plug-in or theme that changes the dashboard.
    Have you tried:
    - deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can't get into your admin dashboard, try resetting the plugins folder by FTP or your hosting site's file manager. Sometimes, an apparently inactive plugin can still cause problems.
    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

  5. DebbieInTX
    Member
    Posted 1 year ago #

    I deactivated all plugins (including network activated plugins) and changed the theme to Twenty Eleven. The Settings / Media screen looks the same (i.e., no Uploading Files section). Could this have been disabled in wp-config or something? My site was set up by someone else, and I'm just now taking over full administration of it.

  6. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Check users and make sure you are admin.

    If so, using ftp or your hosted account, delete the wp-includes folder and wp-admin folder. DO NOT touch the wp-content folder. Download a fresh copy of wp and upload the wp-includes and wp-admin folder to the site.

  7. DebbieInTX
    Member
    Posted 1 year ago #

    Done (except I renamed the wp-includes and wp-admin folders instead of deleting them -- call me chicken ;) ). No change. Does it matter that it is a multi-site configuration?

  8. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    I am not a multi-site user but is there a place for network admin>> all sites>>settings?

  9. DebbieInTX
    Member
    Posted 1 year ago #

    There is a Network Admin > Dashboard > Settings > Network Settings which has an Upload Settings section, but no setting for directory:

    Upload Settings

    Site upload space
    Limit total size of files uploaded to MB
    Upload file types
    Max upload file size KB

    More digging... There is a Network Admin > Sites page with tabs to edit Info, Users, Themes, and Settings for each site. Under the site's Settings, there is "Uploads Use Yearmonth Folders"="1" and "Upload Path"="wp-content/uploads". I changed the first setting to "0" and the second to "media" and Bingo!

    Thank you for helping me find it!

Topic Closed

This topic has been closed to new replies.

About this Topic