WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] How do we exclude author sitemap from displaying? (10 posts)

  1. pmfox
    Member
    Posted 1 year ago #

    I have a single author site and have the Author Archives disabled. It's not necessary.

    Yet, the author XML sitemap shows. I have no use for that as it redirects to the homepage of my site.

    Is there an option to disable the XML sitemap?

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Phil C
    Member
    Posted 1 year ago #

    I also have the same question. Is it not possible to disable the author sitemap?

  3. rvbd
    Member
    Posted 1 year ago #

    I'll have to say that I was wondering how to do this as well. I think one of the problems with enforcing showing the author on sitemap is that bots may be use this information to try and hit the blog login page.

    Love this plugin and would be great if we can turn off the author in the XML sitemap. Thanks.

  4. mik-ost
    Member
    Posted 1 year ago #

    Yes strange behavior. I guess I hadn't author sitemap at all. After last plugin update I have it.
    No idea how to disable it.

  5. pmfox
    Member
    Posted 1 year ago #

    I just got a reply via Twitter. He's working on an update for this.

  6. pmfox
    Member
    Posted 1 year ago #

    The update just fixed it. Thanks.

  7. ajia.im
    Member
    Posted 10 months ago #

    Is there any disadvantages of disabling Author sitemap? will it affect SEO at all?

  8. jrf
    Member
    Posted 10 months ago #

    If your author page is 'default', it will just list the posts the author has written. That is duplicate content and could negatively impact your SEO score.

    If you have author pages with real content, rather than the article link list, having an author sitemap makes sense.

  9. danttony
    Member
    Posted 3 months ago #

    I'm using Version 1.5.2.8 issue still present

    http://sterlingridgeresort.com/sitemap_index.xml

    http://sterlingridgeresort.com/post-sitemap.xml 2014-05-01 15:25
    http://sterlingridgeresort.com/page-sitemap.xml 2014-05-06 07:56
    http://sterlingridgeresort.com/author-sitemap.xml 2014-05-05 21:04

    Cannnot see how to remove - plus all links point to 404's !!!!

    Love a fix :) Thanks guys for your great work

  10. jrf
    Member
    Posted 3 months ago #

    @danttony Please verify that you have the checkbox for 'disable author/user sitemap' checked on the WPSEO -> XML sitemaps settings page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.