WordPress.org

Ready to get started?Download WordPress

Forums

Portfolio Press
How do I use the Full-width template? (20 posts)

  1. car523
    Member
    Posted 1 year ago #

    I noticed lately that my website is showing a 'Meta' and 'Archives' and 'Search' in the sidebar...I'm pretty sure it didn't use to do this, and I liked that 'clean' non-blog, more like a Website look. When I go into Appearance/Widgits, all of the above mentioned widgits are inactive. There are four Footers there under the sidebar that I can't move or change (Footer 1, Footer 2, and so on). It was suggested to me that using the full-width template option might eliminate this problem. Would it? And how do I do that?

    http://www.c-riede.com/

    Thanks!

  2. adventurechick
    Member
    Posted 1 year ago #

    I am trying to do this as well, how did you resolve this?

  3. manishkumarruhil
    Member
    Posted 1 year ago #

    Hi! adventurechick, many theme already have a full-width template. While writing pages, check on right hand side column there you would find option to choose template.

    Else you can create it on your own. Its very easy. Check this link:
    http://millionclues.com/wordpress-tips/make-full-width-page-in-wordpress/

    Reply if still having trouble doing it.

  4. adventurechick
    Member
    Posted 1 year ago #

    Thanks but this doesn't seem to work here. In this theme there is a template called Full-width Portfolio, but it is showing up with a side-bar on my pages. The coding is below:

    <?php
    /*
     * Template Name: Full-width Portfolio
     * Description: A full-width portfolio template with no sidebar.
     *
     * @package Portfolio Press
     */
    
    global $content_width;
    
    if ( of_get_option('layout') == 'layout-1col' ) {
      $content_width = 980;
    } else {
      $content_width = 980;
    }
    
    get_header();
    
    get_template_part( 'content-portfolio' );
    
    get_footer();
    ?>

    [Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum's parser.]

  5. manishkumarruhil
    Member
    Posted 1 year ago #

    If this is affecting your webpage template than it should not show sidebar.

    You can give a link to your website to known what is the matter exactly.

    OR

    you can create another template by taking help from link provided and than select it.

    Are you sure you are changing template of a static page and not trying to remove sidebar from blog or archive page etc.?

  6. adventurechick
    Member
    Posted 1 year ago #

    Thanks so much for your help. You can see the issue here: http://www.cantaarahome.com/?portfolio_tag=cushion

  7. manishkumarruhil
    Member
    Posted 1 year ago #

    Ok so you are trying to remove sidebar from 'tag' and not 'page'. I am not sure about it since I don't have access to your theme but your theme should have a file named something like 'tag.php' or 'tags.php'. Copy and paste it in your child theme directory (if you have made child theme of it else skip this step. It is always recommended to use child theme and not to make changes in main theme since changes will be lost from your theme when it is updates. Checkout: http://codex.wordpress.org/Child_Themes) Now open it (tag.php/tags.php) and remove code line of sidebar. Its should be second line from last.

    Now sidebar should have been gone but width of page you specified may not have been changed (verify it and processed reading only if width have not been changed). In your style.css add following code:

    body.tag .site-content {
    width: 100%;
    }

    OR

    body.tags .site-content {
    width: 100%;
    }

    Or

    body.tag .main {
    width: 100%;
    }

    Or

    body.tags .main {
    width: 100%;
    }

    or

    body.tag .col-width {
    width: 100%;
    }

    or

    body.tags .col-width {
    width: 100%;
    }

    One of above specified code should work. If not than notify us.

  8. adventurechick
    Member
    Posted 1 year ago #

    Thanks so much. I tried the first part that you suggested, but the side bar is still there, so it hasn't worked

  9. manishkumarruhil
    Member
    Posted 1 year ago #

    I apologize but I am not being able to support you very well. I tested your theme and did steps I mentioned above and that worked.

    Have you removed code line:

    <?php get_sidebar(); ?>

    from tag.php ?

    If so and it is still not working than there is extremely rare possibility that your category and tags are interchanged. Try removing same from category.php

    After that if it work than follow succeeding steps else notify me again.

    find:
    .full-width #content, #portfolio.full-width {
    width:100%;
    max-width: 980px;
    }

    and change it to:
    .full-width #content, #portfolio.full-width,
    .tag #content {
    width:100%;
    max-width: 980px;
    }

    This should work.

  10. adventurechick
    Member
    Posted 1 year ago #

    Thanks so much for your help.

    I did try amending the category.php but it made no difference either. I am at a loss now!

  11. manishkumarruhil
    Member
    Posted 1 year ago #

    Ok, so I will do this now that I will make changes in theme, zip it and give a link for you to download. You first delete your theme and than upload it.

    Wait for my next response.

  12. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @adventurechick - are you using a Child Theme? IF not, any changes you make will be overwritten and lost when the theme is updated.

  13. car523
    Member
    Posted 1 year ago #

    @adventurechick

    I never could resolve this and at one point I just got frustrated and simply found a new theme that suits my needs.

    I hope it works out for you, though!

  14. manishkumarruhil
    Member
    Posted 1 year ago #

    Ok Adventurechick, delete 'Portfolio Press' theme from your themes folder (it is very important to delete it). Download links given below:

    1. https://www.box.com/s/9c5lcb3t6cfmerucujjr - This is actual theme file. You can install it directly using your theme install feature in admin panel->appearance->Install themes-> search for 'Portfolio Press' and install it. Or download this file.

    2. https://www.box.com/s/qvr7rpsvrnwnbqw4z4m4 - This is its child theme. Download it.

    Than go to admin panel->appearance->Install themes->upload and upload theme in order. (don't need to upload 1st file if installed it using above told method.

    Than Activate the 'Portfolio Press Child Theme'. It should be displaying correctly now.

    Note that we have removed sidebar and increased width of tags archive only. If you want sidebar to be removed from all pages than wait for my next reply. I will remove side bar from all (categories, posts, archives etc.) and will give you a link to download it.

    If its not not working than please notify me. NOTE THAT IT WILL REMOVE SIDEBAR AND INCREASE WIDTH ON THAT PARTICULAR PAGE ONLY. IF YOU WILL CLICK ON ANY IMAGE ON THAT PAGE AND GO TO THAT. SIDEBAR WILL STILL BE THERE. WAIT FOR MY NEXT RESPONSE TO REMOVE SIDEBAR FROM EVERYWHERE.

  15. manishkumarruhil
    Member
    Posted 1 year ago #

    I have made sidebar disappear from everywhere and content width to stretch to its full. Also made text-align justified to make paragraphs look beautiful.

    If you have downloaded and installed 2nd file from above response than delete it and install this one:
    https://www.box.com/s/k6g2xokp8s0d464oxoz7

    How to install have been told above.

    Tip: you can make drop down of your categories and tags in menu bar as you have already done.

    This should completely resolve your issue but if still having trouble, don't get sad. Just notify me. I should be able to help you.

  16. adventurechick
    Member
    Posted 1 year ago #

    Thank you all for your help. I didn't reinstall, but did remove the reference to the sidebar from archive-portfolio.php

    Now I just have to work out how to increase the page width for that view and I am done.

    Thanks so again, I have really appreciated the support.

  17. manishkumarruhil
    Member
    Posted 1 year ago #

    Find following coding in style.css:
    .full-width #content, #portfolio.full-width {
    width:100%;
    max-width: 980px;
    }
    And change it to:
    .full-width #content, #portfolio.full-widt
    .tag #content,
    .archive-portfolio #content {
    width:100%;
    max-width: 980px;
    }
    (telling on the assumption that you have removed sidebar from both tags and archive)
    IF .archive-portfolio don't work than replace it to just .archive

    If you have removed sidebar from everywhere than change it to:
    .full-width #content, #portfolio.full-width,
    .tag #content,
    .category #content,
    .archive #content,
    .author #content,
    .page #content,
    .single #content,
    .index #content,
    .home #content {
    width:100%;
    max-width: 980px;
    }

    Hope it will work for you.

  18. adventurechick
    Member
    Posted 1 year ago #

    Thanks I tried that but alas no joy. I have no idea why, but this just doesn't seem to want to work.

  19. manishkumarruhil
    Member
    Posted 1 year ago #

    Frankly, I am also not understanding why these are not working for you. I think you should give a shot to child theme I created for you.

    https://www.box.com/s/k6g2xokp8s0d464oxoz7

    Its better that you reinstall your theme first before uploading it. And tell me how it works? Do you want a video tutorial?

  20. Devin Price
    Member
    Theme Author

    Posted 1 year ago #

    Check the theme options. You can select a 1-column layout.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.