WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How do I stop pagination on search results? (5 posts)

  1. mingofaust
    Member
    Posted 7 years ago #

    Hello. I am editing my theme and my search results page seems to be paginating to two results. That is mildly annoying. How do I tell it to stop paginating at all?

    Thanks.

    Danny.

  2. moshu
    Member
    Posted 7 years ago #

    Probably, your blog is set up to show 2 posts, right?
    That applies to every "multiple posts" view, like archives and search.

    So, what is it what you'd like?

  3. mingofaust
    Member
    Posted 7 years ago #

    After hours (literally) trying to find the answer, I posted here and discovered what you just pointed out not five minutes later.

    So, I am upping the "Show at most" posts in the Reading Options to a more reasonable number (like 10) and will instead use a custom query on the home page to display just two posts there, instead of using the Reading Options setting.

    Thank you, moshu.

  4. moshu
    Member
    Posted 7 years ago #

    Another option would be to use the custom query strings plugin that lets you define different post number for different views.

  5. mingofaust
    Member
    Posted 7 years ago #

    The CQS plugin is apparently no longer supported. See:

    Matt Read's own site

    and

    this at Codex

Topic Closed

This topic has been closed to new replies.

About this Topic