WordPress.org

Ready to get started?Download WordPress

Forums

how do I shut off auto-save in the admin panel ? (26 posts)

  1. Samgreen
    Member
    Posted 5 years ago #

    Hello,

    I would like to shut off auto-save in the admin panel. I save often so I don't believe I need it.

    Many times I go to save then publish a post, and have to wait for auto-save to stop saving the draft first.

    Thank you

  2. Samgreen
    Member
    Posted 5 years ago #

    This auto-save of my posts as I pause during my typing is getting more and more in my way.

    Is there a way to shut it off ?

    Thanks !

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    There is no way to turn it off without hacking the core code.

    Auto-save functionality is somewhat critical to WordPress 2.5, and it cannot be easily disabled without breaking other things as well.

  4. iridiax
    Member
    Posted 5 years ago #

    It is annoying, and I wish that there was an easy way to disable it or reduce its frequency.

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    What's so annoying about it? If it's annoying, then it's not working properly on your browser or server or what have you. Because it's totally in the background on a correct installation. You never notice it working. It never interrupts your typing.

    In other words, if you are experiencing problems with it, then you should focus on fixing those problems, not on disabling the thing.

  6. victorstan
    Member
    Posted 5 years ago #

    I think I know what bothers him. Sometimes, in 2.5.0 you got 2-3 drafts of the same post but with different progress. It seems fine now in 2.5.1...at least for me :)

  7. Samgreen
    Member
    Posted 5 years ago #

    It gets in my way. Many times in the past month I have had small edits to make on one post. For over 1,000 posts.

    It is silly for it to save every time I pause between edits.

    One save, which I can take care of for myself, is all that is needed.

    As for drafts, I always save the draft when I am done with it. I don't need wp to be saving it to a draft status when I am about to either save to draft myself, or save and publish it myself.

    I guess if I wanted a number of drafts around, it would be a solution. But I don't need it.

    It saves every few seconds. I don't need that.

    I make an edit and start scrolling down the post, it saves. I don't need that.

    I put in the post title and click on the post body, it saves. I don't need that. When I finish with the post I'll either save it as a draft or save/publish it. If I was concerned I might lose it in the short time I aqm working on it, I'll type it up off line and then do a copy and paste.

    I have no need of the auto-save. All other software I use that has such a feature, I can stop or disable it. Campaign Cartographer, mapping software, has the feature and the company that makes it has it set to easily disable it as many users of CC3 don't like auto-save.

    As someone who has spent 20 years in computer tech support I am always ready to learn new things; however, I fail to see how auto-save can be critical to software.

    If anyone thinks I'm being stupid, then give me a good reason to not have it disabled.

    But try to relate it to my editing needs, as I have just posted above the many reasons I have no use for it.

    I'm not trying to be grouchy, but frankly this is a feature I have no
    need for. There should be away to disable it.

    Is that clear ? Note, I'm not trying to ruffle feathers, I am looking for a solution to something I see as unnecessary.

    Thanks.

  8. Samgreen
    Member
    Posted 5 years ago #

    Ah, found it and change the interval from 60 to 6000.

    Works fine now, which is out of my way. The only thing that happened was it warned me I was editing a file. Yup, I know. I'm the only user.

  9. victorstan
    Member
    Posted 5 years ago #

    The only reason you would like that autosave to be there is your computer crashes/power failure/internet downtime. That way if you write a couple hundred words you are going to be extremly pissed.
    That autosave feature actually saved my ass a few times, but it also annoyed me plenty of times...
    Depends how you look at it :)

  10. Samgreen
    Member
    Posted 5 years ago #

    I save often on my own. So I don't need it.

    I also do export and use the export in phpadmin as well as I edit or add new posts.

  11. moshu
    Member
    Posted 5 years ago #

    Ah, found it and change the interval from 60 to 6000.

    Where?

  12. Evita
    Member
    Posted 5 years ago #

    define( 'AUTOSAVE_INTERVAL', 60 ); // Autosave interval in
    wp-config.php

  13. Samgreen
    Member
    Posted 5 years ago #

    It is in wp-settings.php

    I find the free Agent Ransack locator better than most:
    http://www.mythicsoft.com/agentransack/

  14. jefflouella
    Member
    Posted 5 years ago #

    My issue is that I am an administrator for the blog and I get an email every time a contributor pauses in their typing. I can get 50 emails easy when a contributor is typing one blog. Each email asks me to publish the article, but the person is not done yet. I only want these emails when they press submit for review.

    Is it possible to do that?

  15. Samgreen
    Member
    Posted 5 years ago #

    No idea, but that sounds like something that needs to be fixed.

  16. Samgreen
    Member
    Posted 5 years ago #

    Hmm. Evidently that isn't the setting.

    I started typing in the title of the post first, and clicked on body of post part, and it saved the draft. I'll keep looking.

  17. Exper
    Member
    Posted 5 years ago #

    I've created three plugins using the solutions GamerZ and Untwisted Vortex:
    Disable Revisions and Autosave plugins

    You can easily deactivate Revisions, Autosave or both of them at the same time.

  18. lisavollrath
    Member
    Posted 5 years ago #

    I really don't like this auto-save feature at all, and wish there was a way to shut it off that didn't involve tampering with core code.

    I often write lengthy articles, and find that the URL I've chosen has been rewritten because a draft copy has been saved. For example, three articles I wrote today had a -2 added to their URL, so I had to go in, delete the drafts, and then edit the URL of the published articles.

    This should be something we have some control over.

  19. arminbw
    Member
    Posted 5 years ago #

    Auto-saving is annoying.

    I guess I will set the AUTOSAVE_INTERVAL in wp-settings.php to a higher value, knowing that this is not a clear solution.

    Does Exper´s plugin work only for 2.6, or older versions (e.g. 2.5.1) too?

  20. ninjaboy
    Member
    Posted 5 years ago #

    I would strongly advise you try out the WP-CMS Post Control plugin over at http://wordpress.org/extend/plugins/wp-cms-post-control/

    It not only gives you a control panel to turn auto-save off, but you can also control post revisions, the flash uploader and show/hide every aspect of the write post/page screen, allowing you to hide EVERY aspect of the write screen to simplify it for your users.

  21. Saurus
    Member
    Posted 5 years ago #

    Would it not be easier for you to simply write your posts in a plain text editor, and when done to your taste copy and paste the entire post into your WP post?

  22. Dgold
    Member
    Posted 5 years ago #

    Don't overlook the answers posted above already. This thread is resolved.

    Evita posted a way to change Autosave in your wp-config file. With that method, you will Not have the problem of losing your changes when you upgrade to a new version of WordPress -- a problem which you would have if you actually "hacked the core files" (like wp-settings.php).

    Scroll Up to that solution.

    Secondly, after that, Exper and Ninjaboy posted plugins. Those also work for this.

    Finally, in my experience AutoSave is sometimes quirky when you have the Same Post open on more than 1 computer. It can AutoSave on the computer you aren't typing on, and then the computer that you ARE typing on will throw up a warning. The feature is somewhat annoying, somewhat useful. It's very legitimate to wish to disable it, depending on YOUR particular uses of WordPress. Not everyone is sitting there composing the story of their day in a paragraph blog, some people are entering other kinds of data into Posts, that may involve team-editing (collaboration), minute-to-minute updates (live sports blog), etc. To remain flexible in the audience, WP should endeavor to provide options, and in the event that the core doesn't provide an option, luckily we have workarounds, hacks and plugins to accomplish common needs like this.

  23. Samuel B
    moderator
    Posted 5 years ago #

    @slobjones
    quit bringing up old posts just to start crap
    I and others have had it

  24. enduserxp
    Member
    Posted 5 years ago #

    here you go:
    - open file wp-admin\post-new.php
    - disable wp_enqueue_script('autosave'); at line 14.
    - you're done. bingo !

  25. colinbogart
    Member
    Posted 4 years ago #

    Help. I'm totally new to WP and have no idea where to find the autosave location so I can change from 60 to 6000. Every time the page autosaves, I get thrown back to the beginning of the page I'm writing so it's taking me forever to complete a page. Can someone please explain where the auto-save control is located when I'm looking at the "dashboard"? Thank you.

  26. Shane G
    Member
    Posted 4 years ago #

    Hi,

    Autosave is a good feature and it saves your data whenever any system/broser crash occurs..however you can not disable it from admin panel but you need to edit core wordpress file wp-admin/post.php file and wp-admin/post-new.php.

    How to disable autosave...please refer this:

    [spam link moderated]

Topic Closed

This topic has been closed to new replies.

About this Topic