WordPress.org

Ready to get started?Download WordPress

Forums

[closed] How do I remove the word Home from my page and menu - using Twenty Twelve theme (6 posts)

  1. darrvar
    Member
    Posted 1 year ago #

    How do I remove the word Home from my page and menu?

    Here is my site: http://cellphonebusinessopportunityincharleston.com/

    Please be very specific because I am a novice. Thank you!

  2. To remove it from the Menu, I would go to Appearances > Menu and create a custom menu and add whatever you want. If you don't want home, just don't put it in there.

    As for displaying it on your home page, that's a bit more complicated and you will first need to me a child theme.

    You mentioned that your a novice, so you can decide is making a child them is a challenge you would like to undertake. Otherwise, a good alternative, would be to change the title of the page from Home to something more engaging like "Your one stop shop to cell phone... " ... It's hard for me to come up with a good headline, since there's not much content there. But not only will this make for a more engaging site it will also be good for search engines to figure out what your site is about.

  3. MRB13
    Member
    Posted 9 months ago #

    Hello.
    I am also a novice who would also like to remove the word HOME from the home page.
    How should I retitle the page if there are no "No Pages Found" on the PAGES page? Am I in the wrong place?

    Thank you very much.

  4. alchymyth
    The Sweeper & Moderator
    Posted 9 months ago #

    to remove the word HOME from the home page

    to remove the word from the menu, in your child theme (if you haven't created a child theme yet, review @Christine's reply) edit functions.php and add for instance:

    function twentytwelvechild_page_menu_args( $args ) {
    	$args['show_home'] = false;
    	return $args;
    }
    add_filter( 'wp_page_menu_args', 'twentytwelvechild_page_menu_args', 40 );

    to remove the word from your static front page, edit style.css of the child theme, and add:

    .home .entry-title { display: none; }

  5. dasmonk
    Member
    Posted 6 months ago #

    I have the same problem as the original post-er.

    When I try to create a custom menu without Home via the control panel, the new menu takes but the drop-down menu options become disabled.

    When I tried adding to the code above to a fuctions.php child theme, it didn't work (and it took my site down).

  6. dasmonk
    Member
    Posted 6 months ago #

    Whoops, nevermind the above. I WAS able to get Home removed by playing around with the control panel.

    I definitely would NOT recommend changing your functions.php, as it is unnecessary.

Topic Closed

This topic has been closed to new replies.

About this Topic