WordPress.org

Ready to get started?Download WordPress

Forums

How do I remove Reply / comments box at end of every page (17 posts)

  1. Kat Lake
    Member
    Posted 3 years ago #

    How do I remove Reply / comments box at end of every page in Twenty Ten theme. I have read some forums that talk about changing the code but I don't even know how to get to that code. I am a neophyte and am doing nearly everythign the wysiwig way and only use a littel html on the individual pages. Can anyone help?
    Much thanks.

  2. Easiest way to turn off comments without touching the code is in Settings > Discussion > uncheck "Allow people to post comments on new articles"

  3. wpvivek
    Member
    Posted 3 years ago #

    As simple as that, log-in into wp-admin panel
    go to "Settings" tab and click on "Discussion"

    Now you see a Discussion page, from there un-check third option "Allow people to post comments on new articles".
    In this way you can easily remove reply/comments box at end of every page.

  4. Kat Lake
    Member
    Posted 3 years ago #

    The problem is, I tried that and it didn't work at all. Is this a glitch? Is this part of the theme? very confused.

  5. rvjwhite
    Member
    Posted 3 years ago #

    I didn't get it to work either

  6. Techsuppor
    Member
    Posted 3 years ago #

    Same here , I'm using Wp version 3.1.3. I am not able to remove the comment/Leave a Reply section in all the pages.

    Could not remove it by going to Settings >> Discussion and uncheck the required one.

    Or is it because of the template problem or CSS problem.

    Any other code commenting solution please?

  7. If you are comfortable editing theme files, go into page.php, index.php, loop.php or in whatever other files your particular theme uses the comment function, and remove or comment out the function. It may look something like this:

    <?php comments_template(); ?>

    To comment it out (make it not have any effect on your site) put two slashes in front of it, like this:

    <?php // comments_template(); ?>

    Just do not edit Twenty Ten directly or all your changes will be overwritten the next time you update WordPress. Use a child theme instead.

  8. alchymyth
    The Sweeper & Moderator
    Posted 3 years ago #

    check under 'screen options' in the 'edit page' page in the dashboard, if the 'discussion' tick box is ticked; that will open a 'discussion' field below the page editor, where you can disable comments.

    or 'quick-edit' each page and untick the 'allow comments' box.

  9. Techsuppor
    Member
    Posted 3 years ago #

    @zoonini,
    Thank you. It works :)

  10. Kat Lake
    Member
    Posted 3 years ago #

    Alchmyth,
    Glad it worked for Techsuppor but is not working for me becasue there is no Edit page on my Dashboard. There is the Screen Options that has the check boxes for: Right Now Recent Comments Incoming Links Plugins Site Stats QuickPress Recent Drafts WordPress Blog Other WordPress News ... no Discussion box.
    So maybe that is my problem I am seeing a different version. Maybe I am not listed as owning the site??? Any thoughts anyone?
    Thanks for your input.

  11. Kat Lake
    Member
    Posted 3 years ago #

    Okay I have it now. I have to do that for each individual page. I see what you mean.
    Thanks Alchmyth and Techsuppor and Zoonini

  12. tommr
    Member
    Posted 2 years ago #

    Ahhhhhh
    It was under the QUICK EDIT option!
    I un checked the comments box and presto.

    Thanks everyone

  13. Aditya Jain
    Member
    Posted 2 years ago #

    @alchymyth
    Excellent! Keen observer!
    Thanks a lot.
    It works and is better that other ways which the so called techmasters gives

  14. egg-o-maniac
    Member
    Posted 2 years ago #

    @alchymyth
    you're my hero!

    after spending days on trying to find a neat solution for hiding comments on the static front page finally your tip did the trick.

  15. NSguy
    Member
    Posted 2 years ago #

    Hi, I am new here, I have been a member for 5 minutes now. Just learning to use wordpress along with my main site, I wish I had tried it before.

    I was having the same problem trying to get rid of the reply screen, after reading these post's I found it. I have v3.2.1, it is as @tommr said
    under the "QUICK EDIT" button.

    Thank you all.

  16. Richard Hinds JD
    Inactive
    Posted 2 years ago #

    I just checked in and you guys saved me a lot of time and headache.

    Thank you.

  17. flashharrogate
    Member
    Posted 2 years ago #

    The quickest way to do this is to cut all content from the 'comments.php' page in Appearance > Editor. Then click 'update' and then paste content into text editor to save in-case you ever need it in the future.

Topic Closed

This topic has been closed to new replies.

About this Topic