WordPress.org

Ready to get started?Download WordPress

Forums

How do I remove /home in my homepage permalink in the edit page mode (7 posts)

  1. soulful-real
    Member
    Posted 1 year ago #

    When I am in the edit page mode of my homepage (which I have created a static home page), the permalink is http://www.example.com/home.
    I would like to just have it say http://www.example.com/, how do I go about doing this.

    FYI: example is in place of my website name for this forum purpose only

  2. dwnmedia sarl
    Member
    Posted 1 year ago #

  3. soulful-real
    Member
    Posted 1 year ago #

    My website is a blog site, I just created a custom homepage to show recent post and other content. I don't think the page you refer me to is what I am looking for. I didn't install WP in a subdirectory. Let me know how I can be more clear.

    The reason I want to get rid of the /home is because I wanted to set my homepage as private, but since the permalink has /home, the URL http://www.example.com will still show up for the public. I can only see my private homepage if I add the/home to the end or the URL.

  4. Prasath Mani
    Member
    Posted 1 year ago #

    Hi,
    In WP backend goto
    Settings > Reading > Front page displays > A static page (select below).

  5. dwnmedia sarl
    Member
    Posted 1 year ago #

    I don't really get what it your problem

    when you go on

    1. http://www.example.com/ : what does it show ? and what do you want to show on this page
    2. http://www.example.com/home : what does it show ? and what do you want to show on this page

    Thanks to reply this questions

    BTW : you should first have a look on the WP settings like prasathpree told you on his message yes

  6. soulful-real
    Member
    Posted 1 year ago #

    @prasathpree, thank you for understanding. That did the trick! Phew, I almost pulled my hair out.
    Thank dwnfred for the help and quick response.

  7. soulful-real
    Member
    Posted 1 year ago #

    Oh no! So I went and did as prasathpree mentioned above, Settings > Reading > Front page displays > A static page (select below).

    Then I go to my homepage and set the page visibility to Private and it worked, BUT when I go back to Settings > Reading, The Front page display disappeared (the only thing that is there is blog pages show at most, syndication..., For each..., and Encoding..). And when I visit my homepage, the Visibility in the backend is still set at Private but my page is Publicly visible. (I tested by viewing my homepage in a different browser that I am not logged into my wp-admin) Does anyone else have this issue or did I screw some code up in one of my php files..?!?!?!?

    Please help. By the way if I delete the homepage and also delete it from the trash bin and start over the whole process repeated. ughhhhh

Topic Closed

This topic has been closed to new replies.

About this Topic