WordPress.org

Ready to get started?Download WordPress

Forums

How do I make full blog posts show up on front page? (9 posts)

  1. jrroth
    Member
    Posted 7 years ago #

    Hey,

    I am looking to change some of the php setting at my new blog http://www.thedailyd.com .
    I want to make it so it stops cutting off long posts and just linking to them instead of showing them on the frontpage. Any help would be appreciated...if someone could just take a look and maybe recommend some code.

    Thanks

  2. jrroth
    Member
    Posted 7 years ago #

    bump

  3. Samuel B
    moderator
    Posted 7 years ago #

    Look in the loop:
    http://codex.wordpress.org/The_Loop
    and change
    the_excerpt
    to
    the_content
    http://codex.wordpress.org/Customizing_the_Read_More

  4. jrroth
    Member
    Posted 7 years ago #

    Thanks, I learned some from messing with the loop, but I still can't figure it out. It was already set to the_content. Only when I removed

    <?php
    // Here is the call to only make two posts show up on the homepage REGARDLESS of your options in the control panel
    query_posts('showposts=1');
    ?>

    from the start of the loop do all of the posts show in full. But now I have a problem with the comments, date, time, and author stamps overlapping...would that have to do with another setting in the loop or my stylesheet?

    Thanks

  5. jrroth
    Member
    Posted 7 years ago #

    This is what I have in the loop for the stamps

    <ul class="post_info">
    <li class="date">Posted by <?php the_author() ?> on <?php the_time('F jS, Y') ?> filed in <?php the_category(', ') ?>
    <li class="comments"><?php comments_popup_link('Comment now »', '1 Comment »', '% Comments »', 'commentslink'); ?>

  6. moshu
    Member
    Posted 7 years ago #

    Find that post-info class in your stylesheet and remove the
    position: absolute line

  7. jrroth
    Member
    Posted 7 years ago #

    :D That worked, but now I seem to have multiple stories of each post on the frontpage...not sure what happened...where could I locate how to change that?

    I really appreciate the help.

  8. jrroth
    Member
    Posted 7 years ago #

    I figured it out....I removed a

    <----second layer--->
    I guess it wasn't needed....

  9. jrroth
    Member
    Posted 7 years ago #

    I got everything figured out. Thanks for the help guys.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.