WordPress.org

Ready to get started?Download WordPress

Forums

How do I make a new database for wordpress? (5 posts)

  1. RaymondDay
    Member
    Posted 9 years ago #


  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Try here ?
    http://codex.wordpress.org/Getting_Started_with_WordPress#Installation

    Are you using cPanel / vdeck or Plesk ?

  3. RaymondDay
    Member
    Posted 9 years ago #

    I been trying this for hours. It all way comes back with errors. I looked on line for help and on this board I could not find any thing to help me. So that is why I am posting here.

    I installed wordpress in my Toshiba Magnia SG10 that has e-smith linux installed on it. I can go to wordpress install with this address:

    http://192.168.0.2/wordpress/wp-admin/install.php

    It just tells me error that it can't connect to the database. Asking me if the username and password are right in the wp-config.php file. That it can't contact the database server at localhost. That it my be that my database sever is down.

    I wish it would just say do you want me to auto make a wordpress database? But it don't so I have to spend hours trying to find out how to set one up.

    The first thing I did to make a database was type this on the command line:

    mysqladmin create wordpress
    groupadd mysql
    useradd -g mysql mysql
    mysqladmin processlist

    It looked like it did something but it did not work.

    I then installed phpFormGenerator

    phpFormGenerator made a database that I named wordpress and said all is good. I can go to:

    http://192.168.0.2/phpform/forms/admin/index.php

    and it shows that there is a database.

    But still wordpress says error.

    Then I installed phpMyAdmin 2.6.3-rc1 but when I got to:

    http://192.168.0.2/phpMyAdmin/

    phpMyAdmin gives me this error:

    MySQL said:

    #1045 - Access denied for user: 'admin@localhost' (Using password: YES)

    I guess e-smith will not let you use root, only admin for the database. I used the only password I have that I used to log in. I used root and admin names with no password or with the password, nothing works.

    I know if I log in as admin it goes to a setup. But if I log in as root it goes to the console so I can type in commands. Maybe I need to make a new user for the database I don't know.

    Can any one help me?

    -Raymond Day

  4. RaymondDay
    Member
    Posted 9 years ago #

    After hours and hours and trying to find out what is wrong. All I had to do was this one line:

    "mysqladmin -u root password mypassword"

    The mypassword is my password that I don't what to type in here.

    So the start of my wp-config.php file looks like this but the password is changed to mypassword:

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'WordPress'); // The name of the database
    define('DB_USER', 'root'); // Your MySQL username
    define('DB_PASSWORD', 'mypassword'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    My wp-config.php been like that all the time. I know I had my name and password right. To bad WordPress did not say did you set up a name and password for the database with this line? Then show the line I did.

    I found the help at the end of this web page, thanks to google:

    http://mysqld.active-venture.com/Passwords.html

    I had about 6 webpages open just looking for what would fix it.

    It's been 2 days. No one could help. But I guess because it's around the 4th of July now. I hope this will help others.

    -Raymond Day

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    The reason for the slow response may well have been the command line. The number of people here using the command line is very very small. Glad it's sorted though :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.