WordPress.org

Ready to get started?Download WordPress

Forums

How do I locate the wp-config.php file? (16 posts)

  1. Snoofle
    Member
    Posted 1 year ago #

    I'm having the same problem that others have reported:

    WordPress 3.5 add new media is not working, so it's impossible now to add a new file when I want to post a new post or page.

    From other threads I've found this solution:
    Add: define('CONCATENATE_SCRIPTS', false ); in your wp-config.php file just before require_once(ABSPATH . 'wp-settings.php');

    I'm new at this and don't know how to locate that file. Any help would be appreciated.

  2. leejosepho
    Member
    Posted 1 year ago #

    I think you will find it in public_html, but I know nothing about the tweak you have in mind.

  3. Bill
    Member
    Posted 1 year ago #

    Yes, by default it is located in the directory that also contains wp-content and wp-admin. Your web host may call it something other than public_html though, or it may be installed in a sub-directory.

  4. Snoofle
    Member
    Posted 1 year ago #

    Thanks, but I have no idea how to access any directories. My dashboard lists the following headings:
    Jetpack
    Posts
    Media
    Links
    Pages
    Comments
    Appearance
    Plugins
    Users
    Tools
    Settings
    Gallery
    Track that Stat
    Database

  5. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    You'll need to be able to access your site files via FTP or your host's file management system to make changes to that file. See http://codex.wordpress.org/FTP_Clients

  6. Bill
    Member
    Posted 1 year ago #

    Directories are locations on your server space at your web host. You can access them using FTP software or through your hosting control panel software such as cPanel (at your hosting account).

    Make sure to make a copy before making any changes to this config file or you can kill your site.

    (edit: sorry WPYogi, I didn't refresh recently and your reply wasn't visible before I posted. Yeah, what yogi said.)

  7. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Hey, no problem - yours was better anyway :).

  8. Snoofle
    Member
    Posted 1 year ago #

    Thanks, I'm getting closer...

    My web host is DreamHost.
    It lists the following tools:
    Manage Account
    Manage Domains
    Manage Email
    Manage Users
    MySQL Databases
    One-Click Installs

    and the following Domains:
    Manage Domains
    Registrations
    Reg. Tranfer
    Secure Hosting
    Remap Sub-Dir
    Anonymous FTP
    Mongrel and Proxy

    Thanks--I did back up my account.

  9. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Here's the DreamHost info for using FTP:
    http://wiki.dreamhost.com/Ftp

  10. Snoofle
    Member
    Posted 1 year ago #

    Thank you, but I still don't understand how to access files. I just won't post any photos for now and wait for the next so-called upgrade. Half the time any internet system is "upgraded" it seems to make things worse.

  11. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    It's actually not likely that an upgrade of WP will fix this issue - have you gone through the troubleshooting steps of deactivating all your plugins and switching to a default theme? That's the best place to start with trying to find the problem.

  12. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    Snoofle, since you're on DreamHost you generally don't need to use the concatenate scripts fix anymore (we fixed that on our servers).

    What's your domain? I can take a look for you and see if this is an easy fix.

  13. Snoofle
    Member
    Posted 1 year ago #

    Thanks. It's MichaelSussmanBooks.com

  14. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    There's nothing in the basic config that should be doing that, so I gave your server a kick just in case.

    A couple things of note: You have a handful of out of date plugins. It's possible one of them is at fault here.

    Also you have a lot of unused themes that can be deleted :) Generally deleting everything except the theme you're using (Koi) and the Twenty* themes is a good idea.

  15. Snoofle
    Member
    Posted 1 year ago #

    Thanks. I previously tried deactivating all the plugins, but that didn't do the trick. I just deleted all of the unused themes, but still no go.

  16. Ipstenu-DH
    DreamHost Rep
    Posted 1 year ago #

    Two things to test:

    1) turn off pagespeed on your domain. If it IS that, we can check your apache instance and make sure the pagespeed patch was applied.

    2) Test with the default theme (twentyTwelve) to make sure it's not a change you made to your theme.

    If you want to open a ticket with DreamHost, and provide a username and password, we can have someone take a look for you.

Topic Closed

This topic has been closed to new replies.

About this Topic