WordPress.org

Ready to get started?Download WordPress

Forums

How do I Hide Comment fields only on certain pages (11 posts)

  1. bernwa
    Member
    Posted 3 years ago #

    I'm trying to figure out to have the comments field or boxes not show or be available only on select pages. I don't want it to be global. For instance I don't want it on my home page but would like it on my music page. Any help would be greatly appreciated.
    Thanks!

  2. lindafar
    Member
    Posted 3 years ago #

    If you scroll down to the "Discussion" section on "Add New Post" or "Add New Page" you can uncheck the box that allows comments on that post or page.

  3. bernwa
    Member
    Posted 3 years ago #

    Thanks... I'm a bit unclear. What if I have already created the page that I want to get rid of the comment box?

  4. Pamela Sue
    Member
    Posted 3 years ago #

    If my comments were somehow deactivated on a post, is there anyway to reactivate them? All of my posts since yesterday don't allow for comments and I can't find the reason why. Help!!!

  5. lindafar
    Member
    Posted 3 years ago #

    @ bernwa - you should be able to edit the published page (or post) and scroll down to the Discussion section as mentioned. Then hit the update button on the post/page.

    @pamela sue - I don't know what caused this but you too could check the posts by editing them and making sure the Discussion section is properly checked. You could also check in the Dashboard under Settings > Discussion and make sure everything is correct there.

  6. bernwa
    Member
    Posted 3 years ago #

    No that doesn't work. Unless there is another Discussion button I'm missing. Is it the one on the lower left of my Dashboard? When I select that it takes me away from my selected page. Thanks again for your patience.

  7. lindafar
    Member
    Posted 3 years ago #

    No, it's a section on the page where you created your post (or page). So first click on "All Posts" (or "All Pages"), then find the post you are referring to, click on its Edit link, scroll down to the Discussion section. It's on every create new post (or page) too - you just have to scroll down far enough to see it. Then click the Update button to save the settings (or any changes you want to make to your post or page, for that matter.)

  8. bernwa
    Member
    Posted 3 years ago #

    I'm just not seeing that discussion link you are referring to not matter how far down I scroll. Could it be we have different versions? I have the latest.

  9. lindafar
    Member
    Posted 3 years ago #

    I'm using the latest WP (3.2.1) too - maybe you need to click on "Screen Options" at the top right side of the page (near the Help button) and make sure "Discussion" is checked there too? There are a lot of options you can turn on and off on that panel to decide what you want to display on each page in your Dashboard.

  10. bernwa
    Member
    Posted 3 years ago #

    Yes, that was it! It was turned off on "Screen Options". Works perfectly now. Thanks so much for your patience! I'm new to WP and this has been so helpful.

  11. lindafar
    Member
    Posted 3 years ago #

    Great! Glad to have helped.

Topic Closed

This topic has been closed to new replies.

About this Topic