WordPress.org

Ready to get started?Download WordPress

Forums

How Do I Get this Page to Display Without It Showing in the Menu? (27 posts)

  1. agfreesafety
    Member
    Posted 1 year ago #

    I have a page (called "Thank You") that's supposed to show up after people click on the Send Me Real Estate 101 button on the home page of the website.

    I set the "Thank you" page as private so that it won't show up in the menu.

    It was brought to my attention that people are getting an error page after they click on the "Send Me Real Estate 101" button.

    I've tested, and figured out that this issue is only happening when the "Thank You" page is set to private. When I set it back to Public, the issue goes away.

    The problem, is that we don't want the "thank you" page to show up in the menu.

    How can I alleviate this issue? I would like for this page to function as a public page, without it showing up in the menu (if that's even possible?)

  2. deepbevel
    Member
    Posted 1 year ago #

    Make a custom menu and don't include that page.
    Most theme's allow you to do this under appearance/menus.

  3. agfreesafety
    Member
    Posted 1 year ago #

    Thanks for that insight. I'm trying to create one now.

    But as you can see in this screenshot, I created the new custom menu, but when I try to add pages to it (by clicking the Page arrow to the right of the word page), nothing happens.

    What might I be doing wrong, if anything? It's functioning as if it won't let me add pages to the menu or something.

  4. deepbevel
    Member
    Posted 1 year ago #

    You have to drag the items from the widgets on the left, into the menu, then save the menu. Then, select the new custom menu from the "Theme Locations" widget, and save.

  5. agfreesafety
    Member
    Posted 1 year ago #

    Sorry for sounding like I'm stupid (maybe I am), but where exactly do I drag the Pages widget to?

  6. agfreesafety
    Member
    Posted 1 year ago #

    Where is "the menu?" Thanks again.

  7. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

  8. deepbevel
    Member
    Posted 1 year ago #

    It's that white space to the upper right of the menu items, it says "save menu" above and below the area where you drag the widgets.

    Maybe you didn't create the menu first, you have to do that before you can drag items into it.

    check the link posted above, you'll want to know more about what you can do with custom menus.

  9. agfreesafety
    Member
    Posted 1 year ago #

    Maybe you didn't create the menu first, you have to do that before you can drag items into it.

    I did. The name of the new menu is "Custom Menu." When I drag items into that white space, they go back to their location before I dragged them, they don't stay for some reason.

    At the top of my Menu screen, there's a message that says "You must configure the plugin to enable Facebook for WordPress."

    Might that have something to do with it?

  10. agfreesafety
    Member
    Posted 1 year ago #

    In this screenshot, you can see that I have the "Custom Menu" created and I'm trying to modify it.

  11. deepbevel
    Member
    Posted 1 year ago #

    It's likely it's your browser, try another one or update the current one. Also disable any plugins, then re enable to find out which is causing it.

  12. agfreesafety
    Member
    Posted 1 year ago #

    Man, I don't know what's going on here.

    I tried it in IE, and the Pages widget still won't stay in that white space.

    I was trying it from Mozilla previously.

  13. deepbevel
    Member
    Posted 1 year ago #

    It's happened to me a few times, it was either my browser or a plugin causing it, one time it was my theme. You may want to try another theme just to find out.

  14. agfreesafety
    Member
    Posted 1 year ago #

    I switch the site to another theme, and it's still doing it, in both IE and Mozilla.

  15. deepbevel
    Member
    Posted 1 year ago #

    try disabling the social share plugin, and all other plugins.

  16. deepbevel
    Member
    Posted 1 year ago #

    Unfortunately it's hard to explain how to use custom menus, still not 100% sure you're doing it right.
    After reviewing it myself, you have to first select the check boxes for the items you want to add, then click the "Add to menu" button.
    Then, you can drag the widgets to the position you want in the menu.

  17. agfreesafety
    Member
    Posted 1 year ago #

    Where on the page are the check boxes located that you're referring to?

  18. deepbevel
    Member
    Posted 1 year ago #

    oh my, looks like the widget is collapsed..? just click on it and you should see your pages with checkboxes.

  19. agfreesafety
    Member
    Posted 1 year ago #

    When I try to click on the arrow for "Page", nothing happens.

  20. deepbevel
    Member
    Posted 1 year ago #

    It's the "Pages" widget below the "Custom Links" widget on the left, if you click on "Pages" it should expand and list your pages with the check boxes.

  21. deepbevel
    Member
    Posted 1 year ago #

  22. deepbevel
    Member
    Posted 1 year ago #

    what about the arrows for the other widgets? do they collapse/expand?
    also, I've been assuming you actually have pages on your site, ..right? or is it just categories and or your blog page?

  23. deepbevel
    Member
    Posted 1 year ago #


  24. agfreesafety
    Member
    Posted 1 year ago #

    It's the "Pages" widget below the "Custom Links" widget on the left, if you click on "Pages" it should expand and list your pages with the check boxes.

    I think this screenshot shows that I'm clicking on what you're talking about, and I'm not getting anything to happen when I do so.

    what about the arrows for the other widgets? do they collapse/expand?

    No sir.

    also, I've been assuming you actually have pages on your site, ..right? or is it just categories and or your blog page?

    Yep, this screenshot shows that we have several pages for this site.

  25. deepbevel
    Member
    Posted 1 year ago #

    what about the plugins?

  26. deepbevel
    Member
    Posted 1 year ago #

    I'm convinced you're doing it right. If its not your browser, theme or a plugin, you'll need a more advanced trouble shooter.
    If the problem persists, re post your issue with a title like "Can't expand custom menu widgets" . You'll be able to hide your page once you resolve this.

  27. agfreesafety
    Member
    Posted 1 year ago #

    Thanks, I'll do so right away.

Topic Closed

This topic has been closed to new replies.

About this Topic