WordPress.org

Ready to get started?Download WordPress

Forums

How do I get secondary pages to NOT show up in my main nav? (5 posts)

  1. jaylane
    Member
    Posted 5 years ago #

    Hello,

    I'm trying to create secondary pages that do not show up in my primary navigation. For example, my Web site is at http://www.jaylane.com . I'm trying to put up some pictures of my deck at http://www.jaylane.com/deck . I just don't want to see "deck" showing up in my navigation. Is there any easy way to do this?

    Any help would be greatly appreciated.

    Thanks so much!

    Jay Lane

  2. moshu
    Member
    Posted 5 years ago #

    I don't know what "secondary Pages" are... but you can always read the documentation.
    Template_Tags/wp_list_pages

  3. jaylane
    Member
    Posted 5 years ago #

    Sorry, wrong terminology. I was referring to sub pages.

  4. palamedes
    Member
    Posted 5 years ago #

    I don't see deck in your navigation when you go to that page, however the best way to solve this would be through CSS.

    If you go to your "Blogging" category on your page ( http://www.jaylane.com/category/blogging ) then view the source you'll see the category you're in has a class of current-cat for that LI.

    <li class="cat-item cat-item-38 current-cat">

    by adding some CSS to your styles you can easily say something like;

    .widget_categories ul li.current-cat {
      display: none;
    }

    This would hide that menu option.

    Does this help?

  5. jaylane
    Member
    Posted 5 years ago #

    I actually figured it out. I went into my stylesheet and made the following change:

    <?php wp_list_pages('depth=1&title_li='); ?>

    I'm learning my way around PHP a little bit.

    Thanks for the help.

    Jay

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.