WordPress.org

Ready to get started?Download WordPress

Forums

How do I get rid of '/wp' on the end of my URL? (28 posts)

  1. lizsaskia
    Member
    Posted 3 years ago #

    I originally had a different website uploaded to my webhost, then decided to create a wordpress one instead. After completing the wordpress site I deleted the original site off the server but the wordpress site will still only view if I add '/wp' to the end of my domain. If I just type my URL in I get an index list (which obviously I don't want people seeing!) Another domain name I was working on didn't have this problem so I am assuming it is something to do with having a previous index file uploaded?

    I have tried following the instructions at:

    http://codex.wordpress.org/Changing_The_Site_URL

    and

    http://codex.wordpress.org/Moving_WordPress#Moving_WordPress_Within_Your_Site

    but managed to mess it up and had to start my site again from scratch. I'm now really nervous about messing it up again. Does anyone have any simpler instructions?

  2. 123milliseconds
    Member
    Posted 3 years ago #

    you might have a .htaccess leftover from old site

  3. 123milliseconds
    Member
    Posted 3 years ago #

    >>so I am assuming it is something to do with having a previous index file uploaded?

    If you deleted the full old site; there should be no leftovers

    what is the content of your currnet html or htdocs folder on server

  4. lizsaskia
    Member
    Posted 3 years ago #

    Thanks for answering - the contents of my public_html folder is:

    CGI-bin folder
    WP folder
    Error_log
    wp-config.php

    Should I have deleted anything else?

  5. 123milliseconds
    Member
    Posted 3 years ago #

    There are no leftovers; so its not leftovers causing a problem

    Sorry did you do a ls --all

    to show .htaccess files as well

  6. keesiemeijer
    moderator
    Posted 3 years ago #

    Do you have a index.php in your root directory
    It should have this in it:

    <?php
    /**
     * Front to the WordPress application. This file doesn't do anything, but loads
     * wp-blog-header.php which does and tells WordPress to load the theme.
     *
     * @package WordPress
     */
    
    /**
     * Tells WordPress to load the WordPress theme and output it.
     *
     * @var bool
     */
    define('WP_USE_THEMES', true);
    
    /** Loads the WordPress Environment and Template */
    require('./wp-blog-header.php');
    ?>
  7. 123milliseconds
    Member
    Posted 3 years ago #

    This would be the easy option if you did it the first time

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    Copy (NOT MOVE!) the index.php and .htaccess files from the WordPress directory into the root directory of your site (Blog address). The .htaccess file is invisible, so you may have to set your FTP client to show hidden files. If you are not using pretty permalinks, then you may not have a .htaccess file. If you are running WordPress on a Windows (IIS) server and are using pretty permalinks, you'll have a web.config rather than a .htaccess file in your WordPress directory. As stated above, copy (don't move) the index.php file to your root directory, but MOVE (DON'T COPY) the web.config file to your root directory.

    -----

    keesiemeijer spotted the missing files correctly

    you did not move the files correctly; you did not follow http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

  8. lizsaskia
    Member
    Posted 3 years ago #

    I have index.php in my wp folder - should I move it to my public_html folder?

  9. lizsaskia
    Member
    Posted 3 years ago #

    Sorry I meant copy! Still looking for the .htaccess files. I have checked the show hidden files box

  10. lizsaskia
    Member
    Posted 3 years ago #

    I found wp-config.php - is that the right file? Nothing changed when I moved it. Have copied index.php

  11. keesiemeijer
    moderator
    Posted 3 years ago #

    In what directory are all your WordPress files?
    Are all your WordPress files in your "WP folder"?

  12. lizsaskia
    Member
    Posted 3 years ago #

    Yes, apart from the index and the config files I have just moved (copied the index)

  13. keesiemeijer
    moderator
    Posted 3 years ago #

    And you want them in the root of your site, without the "WP" at the end of the url?

    check "WordPress address (URL)" and the "Site address (URL)" under Settings > General in the wp-admin.

    is there /WP folder or /WP at the end of these urls?

  14. lizsaskia
    Member
    Posted 3 years ago #

    Yes there is for both of them - when I tried removing the wp I got an error message and lost the dashboard and the site. I couldn't figure out what to change in the c-panel so I ended up reinstalling wordpress!

  15. keesiemeijer
    moderator
    Posted 3 years ago #

    You didn't have to do that. You can move the files in WP folder to your root directory.

    Be sure that the wp-config.php is pointing to the correct database.

  16. lizsaskia
    Member
    Posted 3 years ago #

    Ok I moved them and it's messed up the site again! Moved them back and it's still not working - just showing an index of my files when I type in the URL

  17. lizsaskia
    Member
    Posted 3 years ago #

    Ok got it back by deleting the index.php from the root folder.

  18. keesiemeijer
    moderator
    Posted 3 years ago #

    Copy all your wordpress to the root folder including index and wp-config. You told wordpress earlier that is where they live.
    and then tell me what you see. wait before you do anything else.
    check also if wp-config.php has the correct database values.

  19. lizsaskia
    Member
    Posted 3 years ago #

    Just checking, as this is where I messed up earlier - I change the wordpress and site url to remove the /wp in Settings, then move all the files to the root folder. As far as I can see the database is the one I set up when I installed wordpress.

  20. keesiemeijer
    moderator
    Posted 3 years ago #

    Yes remove the "/wp" (with the forward slash) of the "WordPress address (URL)" and the "Site address (URL)" under Settings > General in the wp-admin. Do not worry about the error message (if you get one) and do not try to see your blog at this point! You will probably get a message about file not found.
    Backup all your wordpress files.
    move all your files to the root folder.

    Can you see your website under the new address?

  21. lizsaskia
    Member
    Posted 3 years ago #

    Ok it's worked but I've lost the background image! When I click on background on the dashboard it comes up with an error and says there is a 'misconfigration'. So close!

  22. lizsaskia
    Member
    Posted 3 years ago #

    There is still wp-content in the wp folder that it won't let me move

  23. lizsaskia
    Member
    Posted 3 years ago #

    I've moved the content file so the wp folder in now empty but the background it still coming up with the error

  24. keesiemeijer
    moderator
    Posted 3 years ago #

    The urls in your stylesheet are pointing to the old directory. Do a search and replace to the new url.
    If you have problems with missing images that you've uploaded, you need to change the path to the images in every post_content. You can do this with a search and replace plugin: http://wordpress.org/extend/plugins/search-regex/

  25. lizsaskia
    Member
    Posted 3 years ago #

    I can't get on to the dashboard now - when I try to log in it sends me to my home page. Not sure exactly what I should be changing in the code. How do I do a search and replace?

  26. keesiemeijer
    moderator
    Posted 3 years ago #

    Just to be sure, you can see all your posts but the layout is broken and you cannot login?
    First we try to get you to login. after that we do the layout.
    Can you login when you put this after your url "/wp-login.php". www.example.com/wp-login.php
    Also try www.example.com/wp-admin/upgrade.php

    When I click on background on the dashboard it comes up with an error and says there is a 'misconfigration'.

    Can you show me the full error message?

  27. lizsaskia
    Member
    Posted 3 years ago #

    Thank you so much for your patience! I was trying unsuccessfully to log in through the link on my web host, but I managed to login as you suggested above and the dashboard is now working and I have managed to re-upload the background image! And the /wp is gone! You are a star! :)

  28. dancr
    Member
    Posted 2 years ago #

    I have the same problem. I have to add /wp/ to the end of my URL to access my site. I have tried to go to Settings > General and change the URL but there are no settings on my screen. http://codex.wordpress.org/Settings_General_Screen is what the General Settings screen should look like but mine doesn't.

Topic Closed

This topic has been closed to new replies.

About this Topic