WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
[resolved] How do I disconnect the event page from the home page? (14 posts)

  1. rainestorm
    Member
    Posted 1 year ago #

    So, I'm using this plugin on a development site and I've noticed that the Calendar event seems to be automatically tied to the home page for some reason.

    http://wordpress.rainestorm.com/

    It should be on this page: http://wordpress.rainestorm.com/performance-schedule

    Anyone have any idea why it's doing this?

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. davejampole
    Member
    Posted 1 year ago #

    Your Home page and Performance Schedule page look to be the same page.

  3. rainestorm
    Member
    Posted 1 year ago #

    "Your Home page and Performance Schedule page look to be the same page."

    Yes, I don't know why. The Performance Schedule page is specifically set to go to that page in my Menu setup.

  4. davejampole
    Member
    Posted 1 year ago #

    Create a separate page for your performance schedule; remove the ai1ec from the Home page and place it on the just created Performance Schedule page.

  5. rainestorm
    Member
    Posted 1 year ago #

    "remove the ai1ec from the Home page"

    I don't see ai1ec anywhere in my backend.

  6. davejampole
    Member
    Posted 1 year ago #

    Let's back up a few steps. Did you create your site either by coding it yourself or using a theme you got from somewhere, or did someone build the site for you? You said in your original post "...the Calendar event seems to be automatically tied to the home page for some reason."

    On your WordPress dashboard, click Events > Setting to get to the ai1ec setting page. On the Viewing Events tab in the Calendar Page field, you should see the name of the page in which the calendar will display. If you see 'Home Page' and you want to change it, simply click the dropdown arrow and select the page in which you want the calendar displayed. You can also select the view you want as the default view.

    Notice that you can select the possible views to be enabled, but only one as the default view. Select whatever settings you want. When you are done making changes, simply scroll down and click 'Update Settings'. Go to your website and refresh the page. You should see the result of the change(s) you made on the settings page.

  7. rainestorm
    Member
    Posted 1 year ago #

    Sorry, I was unclear. I built the website using a WordPress template. I installed the All-in-One plugin and changed the CSS of the Calendar. In the Events > Settings > Viewing Events tab, I have the Calendar page set to Performance Schedule. I also have the Performance Schedule set as a menu tab in Menus. However, for some reason, the Performance Schedule page seems to be automatically linking to and supplanting the home page.

  8. davejampole
    Member
    Posted 1 year ago #

    Explain '...changed the CSS of the calendar...'

    The problem sounds like it has something to do with the linkage between the Home page and the Performance Schedule page. On Appearance > Menus check the URLs and make sure they are set correctly.

  9. rainestorm
    Member
    Posted 1 year ago #

    Explain '...changed the CSS of the calendar...'

    In the Calendar Theme Options, not the file itself.

    The URLs in Appearance > Menus are set correctly.

  10. davejampole
    Member
    Posted 1 year ago #

    Calendar Theme Options are not a problem, all they do is change colors, shadows, etc. I thought that maybe you added some changes to the theme stylesheet that might be at fault.

    Have you thought about deactivating the ai1ec plugin and seeing what happens? Also, create a new test page and set that as the calendar page and see what happens.

  11. rainestorm
    Member
    Posted 1 year ago #

    Stupid-stupid-stupid-stupid-stupid-stupid-stupid-stupid-stupid.

    I didn't have my Front page display set to a static page. ARRRRRGGGGHHHH!

    Stupid-stupid-stupid-stupid-stupid-stupid-stupid.

    Thanks for the help, davejampole. Creating a test page led to me to solution.

    Oy.

  12. rainestorm
    Member
    Posted 1 year ago #

    Resolved.

    Thanks again, davejampole.

  13. davejampole
    Member
    Posted 1 year ago #

    Glad you solved the mystery.

    Now it's your turn to something good for someone.

  14. rainestorm
    Member
    Posted 1 year ago #

    If I can I will. ;-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags