WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How do I disable Mobile Theme in Jetpack 1.8 = broken with Thesis (12 posts)

  1. robjr
    Member
    Posted 1 year ago #

    I upgraded to Jetpack 1.8 and activated the Mobile Theme feature, now my Thesis sis is totally black - all white. I disabled Jetpack and everything back to normal. How do I disable the Mobile part and keep the rest of Jetpack activated? Need for stats...thanks

  2. Michelle Langston
    Theme Wrangler at Automattic
    Posted 1 year ago #

    Hi robjr,

    You can disable the Mobile Theme by navigating to the Jetpack Dashboard (Jetpack > Jetpack in your WordPress Dashboard). Find the "Mobile Theme" module and click on the "Learn More" button. After you click that button, the "Deactivate" button will appear to the right of the "Learn More" button. Click "Deactivate" and you'll be set.

    Did the Mobile Theme cause your site to turn white on both the desktop and mobile view, or just the mobile view?

  3. robjr
    Member
    Posted 1 year ago #

    I finally figured it out, but thanks for the help - appreciate it :)

    It turned white everywhere...strange, was looking forward to trying it.

  4. davert
    Member
    Posted 1 year ago #

    I appreciate your posting the shutoff instructions!

    I tried it but since it serves to iPad owners by default (I'd like them to get the regular theme) and has no ad options... I wanted to return to my original mobile theme.

  5. zendim
    Member
    Posted 1 year ago #

    Does anybody know how to hack this mobile feature a bit? It works fine, but I had a background and some other pictures working and it stripped everything out. I can't figure out where the code is for this little dude....

  6. BradyDale
    Member
    Posted 1 year ago #

    Thanks for this. I thought I had deactivated it, but I didn't.

    It's worth noting that the mobile theme doesn't appear to be compatible with the ComicPress Theme - which is a big theme heavily used by makers of webcomics.

    By not-compatible, what I mean is this: your comic disappears on mobile devices. Not that the whole site breaks down.

    But, when the whole point of your WordPress site is the comic and not the words, that's a pretty big failure. So I think it's fair to say that Jetpack mobile is totally incompatible with ComicPress.

    My site hasn't worked on mobile devices for days now, till I found this, which is a real bummer. Seems okay now once I deactivated.

  7. khitrenovich
    Member
    Posted 1 year ago #

    @davert:
    1) I get my regular theme on iPad with Jetpack 2.0.2
    2) Just posted some simple instructions on how to enable ads in Jetpack mobile theme in my blog, enjoy :)

  8. mikepoynton
    Member
    Posted 1 year ago #

    I followed the instructions to deactivate the mobile feature of Jetpack. But there is no option to deactivate on the Learn More screen. Ideas?

  9. mikepoynton
    Member
    Posted 1 year ago #

    Nevermind. I was looking in the wrong place. Thanks!

  10. PositivelyRandy
    Member
    Posted 1 year ago #

    I just posted the same thing. Then navigated to Jetpack instead of opening an old tab for that page. THEN the Deactivate Button showed up.

    (It appears that my original post was deleted.)

  11. Gem Webb
    Member
    Posted 1 year ago #

    This really helped. Thanks so much for helping find that button hidden in LEARN MORE. You figure it would be more intuitive to put it under customize...

  12. richard.sauve
    Member
    Posted 1 year ago #

    This is really a confusing way to address the configuration.

    Generally I wouldn't have that to say about the WordPress UI, but this particular approach creates a very awkward UX that is far from obvious.

    It should absolutely be moved to the configuration page, or instead of/in addition to the 'Learn More,' it should be replaced with 'Deactivate.'

    Hopefully this will be addressed by the Automattic team.

Topic Closed

This topic has been closed to new replies.

About this Topic