WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How do I create sitemap.xml and sitemap.xml.gz files (8 posts)

  1. offgridd
    Member
    Posted 5 years ago #

    Hi

    I have a WP self-hosted blog using WP 2.6

    I have successfully uploaded Google Sitemap Generator Plugin 3.1.0.1 to wp-content/plugins directory via ftp - FileZilla

    Please advise in very simple steps (please accept apologies if this is a stupid question):

    How do I create the following two files 1) sitemap.xml and 2)sitemap.xml.gz?

    Many thanks for your help with this question.

    Kind Regards

    Pat

  2. Start1
    Member
    Posted 5 years ago #

    1. In your FTP (I use FireFTP) rightclick in the server window (in the root folder of your WP installation) -> Create File
    2. Write inn sitemap.xml
    3. Do the same with sitemap.xml.gz
    4. CHMOD it to 666 (right click on the files -> Properties -> 0666

  3. offgridd
    Member
    Posted 5 years ago #

    Hi Start1

    Many thanks for your reply.

    Filezilla doesn't allow me to create these files.

    Kind Regards

    Pat

  4. Start1
    Member
    Posted 5 years ago #

    1. Make a empty file called sitemapxml.txt and sitemapxmlgz.txt in Notepad
    2. Upload them to the server
    3. Rename them to sitemap.xml and sitemap.xml.gz
    4. Dont forget to CHMOD to 666

  5. offgridd
    Member
    Posted 5 years ago #

    Hi

    Thank you for your time.

    I uploaded the files to the server and I renamed them.

    When I try to open them to CHMOD, by rightclicking, I got the following messages:

    RE sitemap.xml

    The XML page cannot be displayed
    Cannot view XML input using style sheet. Please correct the error and then click the Refresh button, or try again later.

    --------------------------------------------------------------------------------

    XML document must have a top level element. Error processing resource 'file:///C:/Documents and Settings/Patrick/My Documen...

    RE sitemap.xml.gz

    The file could not be opended:
    No program has been associated on your computer with this file type.

  6. Start1
    Member
    Posted 5 years ago #

    Ok Patrick ;) Did you try to open the files on your computer? That wont work ;) You have to CHMOD the files in an FTP-client on the server/webhotel, not on your harddrive/PC.

  7. offgridd
    Member
    Posted 5 years ago #

    Hi Smart 1

    All sorted.

    Many Thanks

    Kind Regards

    Pat

  8. apopilot
    Member
    Posted 5 years ago #

    Do you turn the CHMOD 666 back to 644?

Topic Closed

This topic has been closed to new replies.

About this Topic