WordPress.org

Ready to get started?Download WordPress

Forums

How do I change to the one column no sidebar template in TwentyTen?? (13 posts)

  1. m_ms09
    Member
    Posted 3 years ago #

    I'm using the Twenty-Ten theme on my own host/server, and there's a template for one column with no sidebar (onecolumn-page.php is the file). In the WordPress instructions, it says to "just choose the “One column, no sidebar” template" with no further explanation:
    http://codex.wordpress.org/User:Dronix/T…

    My wordpress user interface looks like this (with the template I want circled):
    http://www.emasuvajac.com/wpscreenshot.png

    So, where is it that I just "choose" which template I want to use, as wordpress.org says?

    (I've already tried copying and pasting the code from the onecolumn-page.php file into the index.php file...and yes, it does become one column, but I lose the ability for people to make comments or access the post as a single page.)

    Thanks!

  2. m_ms09
    Member
    Posted 3 years ago #

    I've read that you have to go to "edit page" and then "page attributes" - but I have NO IDEA where this is.

  3. m_ms09
    Member
    Posted 3 years ago #

    Ok, I've found the the "Edit Page" and then "Page Attributes" section but only for the pages that I've added to the wordpress site (ie. an added bio page) - not for the actual HOME PAGE where all of my posts are.

    Where do I go in order to change over to the no sidebar template for the main, home page (blog.emasuvajac.com).
    My interface looks like this: http://www.emasuvajac.com/wpscreenshot.png

    Thanks!

  4. alderstone
    Member
    Posted 3 years ago #

    I'm watching this thread. Curious about how to make this happen.

  5. govpatel
    Member
    Posted 3 years ago #

    when you click on edit page in Page Attributes there is Templates dropdown click on the arrow and you will the templates there select the one you want.

  6. alderstone
    Member
    Posted 3 years ago #

    Bingo.

    Thanks very much, Govpatel.

    One clarification that may help other novices like me: I went looking at first for a page or menu item called "page attributes".

    Instead, I found it by clicking on "pages" in the dashboard menu, so that the page title is "edit page". From there, I found the template drop down menu on the right side. Only two options in it: default and "one column, no sidebar".

    Excellent. Just what I needed for some pages.

  7. mikepopl
    Member
    Posted 3 years ago #

    Thanks to advices above I was able to set "one column.." appearance of pages I created but what about "Home" page?

    I can't find where I can define its content and how to force "one column, no side bar" templete.

  8. jayc
    Member
    Posted 3 years ago #

    I have the onecolumn-page.php in my default directory but when I go to edit pages in the admin panel, only 'default template' shows-up in the templates drop-down menu. Anybody know why?

    Thanks

  9. govpatel
    Member
    Posted 3 years ago #

    If you are using home page as post page then there is not template to make it a one column page.

  10. jayc
    Member
    Posted 3 years ago #

    This is on a separate page i added, not the posts page

  11. govpatel
    Member
    Posted 3 years ago #

    did you follow on how make template here
    http://codex.wordpress.org/Templates and
    did you put in your theme folder along with templates if you did it should pick it up in admin.

  12. jayc
    Member
    Posted 3 years ago #

    This is actually the 'oncolumn-page.php' that comes in the default install of 3.0 - wondered about naming convention, used to be 'page-mytemplate', not 'mytemplate-page'

  13. jayc
    Member
    Posted 3 years ago #

    Turns out it was a css theme-naming issue, its fine now - thanks

Topic Closed

This topic has been closed to new replies.

About this Topic