WordPress.org

Ready to get started?Download WordPress

Forums

How do I change the edit post page (12 posts)

  1. donrock7
    Member
    Posted 4 years ago #

    I messed up & hit 1 when the edit post asked for the number of posts I wanted to show. How do I change this back to 20 like it was before I changed it?
    donrock

  2. Avrohomd
    Member
    Posted 4 years ago #

    I think you want on your dashboard:

    Settings > Reading

  3. donrock7
    Member
    Posted 4 years ago #

    That appears to set the number of posts per page. What I need is to reset the number of posts on the edit post page. Where it shows all the posts & where you can edit them. Right now it just show one of the post & I want all of them.

  4. Avrohomd
    Member
    Posted 4 years ago #

    Now I think I understand what you want. I was happy when I learned this:

    At the top right corner of your dashboard it is written: 'Screen Options'. Click on that and a panel opens with what you want.

    You can also change there what sections will appear on your dashboard.

    [signature moderated Please read the Forum Rules]

  5. This is the same as this other post: http://wordpress.org/support/topic/339163?replies=4

    Multiple posts for one problem isn't nice :)

    Anyway, you can't EDIT more than one page at once.

  6. donrock7
    Member
    Posted 4 years ago #

    Ipstenu,
    Sorry about doing something that isn't nice. I thought it would be a different subject. Still trying to figure it out.

  7. donrock7
    Member
    Posted 4 years ago #

    Avrohomd,

    Where on that page will I find what I need? I don't see anything that helps me. Is it that I don't know what to look for or is it not on the page. How about the HTML of the "edit post page"?

    Don

  8. donrock7
    Member
    Posted 4 years ago #

    Avrohomd,

    Where on that page will I find what I need? I don't see anything that helps me. Is it that I don't know what to look for or is it not on the page. How about the HTML of the "edit post page"?

    Don

  9. donrock7
    Member
    Posted 4 years ago #

    Sorry about the double entry? Spacing out over this problem.

  10. syncbox
    Member
    Posted 4 years ago #

    You must be talking about how many pages are LISTED in the list of all the pages you have.

    How this is managed depends upon the version of WordPress you are using. If you are using 2.8.5, there is a list of links at the top that include All | Published | Drafts, etc

    Earlier than 2.8.5, one version was really messed up and didn't have the option to set the number and it defaulted to 15. You had to use a plugin to modify that.

    Earlier... I forget how it was managed. It's a great reason to update your version.

    However, it IS the edit-pages.php file in the wp-admin directory that controls this... but it isn't really a great idea to modify core files. Better to use the admin settings or a plugin.

  11. donrock7
    Member
    Posted 4 years ago #

    syncbox,

    Thanks for the answer but I got it fixed maybe you can help me with another problem though. The sidebar is only showing on the 1st page instead of all of them like I want. I must have done something because they worked when I first put them on.

    Don

  12. syncbox
    Member
    Posted 4 years ago #

    Are these actually WordPress Pages or posts in categories?

    If Pages, are they all using the same Page template?

    If not the same, is the get_sidebar() function the same in all page templates (including the default page.php file)?

    Are you using any conditional logic to display the sidebar.php file? as in <?php if (is_page('n') {//do this} else {//do something else } ?>

    if yes, show me the code AND a url to the site would be good so I can sse the problem in action.

    Or, hopefully, you already have this fixed!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.