WordPress.org

Ready to get started?Download WordPress

Forums

How do I change my blog urls? (17 posts)

  1. davcarst
    Member
    Posted 7 years ago #

    Hi. New to WordPress. I have a quick question: How do I change the actual urls to my blog? I've noticed many who use WordPress have urls that are named after their entires (i.e. http://www.site.com/my_first_post_yay!/) and yet after installing WordPress, my posts seem to be http://www.site.com/?p=1. Any help would be great. Thanks in advance!

  2. drmike
    Member
    Posted 7 years ago #

    You need to set the permalink options. Dashboard -> Options -> Permalinks IIRC.

    Hope this helps,
    -drmike

  3. davcarst
    Member
    Posted 7 years ago #

    Alright, I did that and it changed my urls, but now when I click the titles, they don't exist :( (i.e. http://www.site.com/2007/01/13/i-fn-rock/ shows up on my main blog page but when I click the title, the page doesn't exist). Thanks again!

  4. moshu
    Member
    Posted 7 years ago #

    Is site.com your domain or are you using it as an example? You shouldn't!!!
    For example ALWAYS use example.com

  5. davcarst
    Member
    Posted 7 years ago #

    No, site.com isn't my site, lol. I should have used example.com ;) Actually, mansmanblog.com is my site. And if you visit it, you can see that although I have successfully changed the urls of mt posts, the posts don't exist there.

  6. moshu
    Member
    Posted 7 years ago #

    It is a very useful habit to READ about what you are doing (preferably before the action ;)
    http://codex.wordpress.org/Using_Permalinks

  7. davcarst
    Member
    Posted 7 years ago #

    Well, I enjoy throwing crap to the wall until something sticks ;)

    I've now read it and I'm still clueless.

  8. moshu
    Member
    Posted 7 years ago #

    Bottom line: You need a .htaccess file with the re-write rules generated by WP in it.

  9. vkaryl
    Member
    Posted 7 years ago #

    And mod_rewrite must be enabled by your host.

  10. davcarst
    Member
    Posted 7 years ago #

    It's there. And it still isn't working.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  11. vkaryl
    Member
    Posted 7 years ago #

    Okay, yes, that's the .htaccess needed. But you should just to be on the safe side check with your host (or use a phpinfo file) to make sure mod_rewrite is enabled.

  12. davcarst
    Member
    Posted 7 years ago #

    How do I enable it with my host?

  13. moshu
    Member
    Posted 7 years ago #

    Ask them :)

    According to the gurus you need mod_rewrite and Allow Override.

  14. vkaryl
    Member
    Posted 7 years ago #

    You contact your tech support and ask if it's enabled; if it's not, you ask them if they'll enable it. They might possibly say "no" - some hosts do.

    Um. You're not on a windoze server are you?

  15. davcarst
    Member
    Posted 7 years ago #

    A simple Google search revealed this about my hosting (GoDaddy):

    Mod_rewrite is an Apache web server module installed on all of our Linux severs by default; it does not have to be installed or enabled. Our Linux hosting accounts support most mod_rewrite functionality.

    You will not need to enable mod_rewrite in your httpd.conf, as this is handled at a global level. All you will need to do is add the desired code to the body of your .htaccess file.

    So, should I still call them?

  16. vkaryl
    Member
    Posted 7 years ago #

    Ah. Can't help you further, I don't know anything about godaddy. You might try a search for the several threads where those knowledgeable about that host have posted various fixes.

  17. davcarst
    Member
    Posted 7 years ago #

    Got it working. I deleted my original .htaccess and created a new one.

    Thanks to everyone, even you moshu, you smart ass ;P

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.