WordPress.org

Ready to get started?Download WordPress

Forums

How do I add a digital pic to blog? (16 posts)

  1. ErinKaese
    Member
    Posted 8 years ago #

    I want to add an image i have saved from my digital camera to my wordpress blog...How do i do it??

  2. manstraw
    Member
    Posted 8 years ago #

    get the picture from your camera to your computer hard drive. *know where you put it*

    then, in wordpress, use the upload function. in 2.x, it's right under the box where you type the body of a post. follow what it tells you. you'll have a picture on your site.

  3. MrMarco
    Member
    Posted 8 years ago #

    ErinKaese - I've been wanting to do the same thing. I've tried the upload function but always get an error message:

    "Unable to create directory /home/*****/public_html/wordpress/wp-content/uploads/2006/02. Is its parent directory writable by the server?"

    Don't know what I'm doing wrong, or need to do to fix it.

    Manstraw, any ideas?

  4. manstraw
    Member
    Posted 8 years ago #

    it wants to write to the directory.

    while in wp-content, do this:

    chmod 666 uploads

    If you can't log in with ssh, then do it in your ftp program. basically you want to click on the w's for write permission for every user.

    If 666 doesn't work, try 777

  5. ErinKaese
    Member
    Posted 8 years ago #

    There is no upload function under the main writing space?? under the writing space are: post status, post slugs, trackbacks, Edit time etc...nothing with word "upload" what am i missing?

    erin

  6. MrMarco
    Member
    Posted 8 years ago #

    ErinKaese
    What version of WP are you using?

    Manstraw
    I don't have an uploads folder in WP-Content. Should the content folder be changed so WP can write one in?

  7. ErinKaese
    Member
    Posted 8 years ago #

    I am guessing 1.5.2 -- which is listed under the Word Press logo on my write page...our web designer hooked us up with wordpress... as the blog host which is incorporated into our site. Clearly i need help! :)

  8. MrMarco
    Member
    Posted 8 years ago #

    Erin - Why not try to upgrade to the new version 2.0.1

    http://wordpress.org/download/

    There is a good description on how to upgrade on one of the links. I would suggest speaking with your designer first to be sure. Or maybe someone else here knows a little more about it than I do. But I was running WP 2.0 and I had the upload function. I upgraded to 2.0.1 and it's still there. Of course I'm STILL unable to upload pics, but I'm sure it's a small fix from here.

  9. manstraw
    Member
    Posted 8 years ago #

    It's recommended you upgrade from 1.5.2 to 2.0.x, for securty reasons. Upload is also easier, as I described.

    In 1.5.2, you need to turn on the upload function. Look in options (I think). And instead of being in the write area, there's a separate tab at the top for it when you want to upload something.

  10. >> It's recommended you upgrade from 1.5.2 to 2.0.x, for securty reasons.

    Did I blink and miss an announcement about that?

  11. manstraw
    Member
    Posted 8 years ago #

    They're not fixing security risks in older versions.

  12. moshu
    Member
    Posted 8 years ago #

    It's recommended you upgrade from 1.5.2 to 2.0.x, for securty reasons.

    That's simply NOT true!
    1.5.2 was and is a very secure version. No security fixes came with 2.0. In my personal opinion quite the contrary: forcing users to change permissions on folders to be writable it is a risk. Especially that people tend to forget to change it back.

  13. Karne
    Member
    Posted 8 years ago #

    I get this same message - "Unable to create directory /home/*****/public_html/wordpress/wp-content/uploads/2006/02. Is its parent directory writable by the server?"

    And when you say - "it wants to write to the directory.

    while in wp-content, do this:

    chmod 666 uploads

    If you can't log in with ssh, then do it in your ftp program. basically you want to click on the w's for write permission for every user.

    If 666 doesn't work, try 777"

    I have no idea what that means. I just installed WP yesterday, so I'm sure I have the latest version. I'm using cPanel File Manager. I'm just learning this, so I need a little more info. Thanks...

  14. manstraw
    Member
    Posted 8 years ago #

    Moshu, I didn't say 1.5.2 is insecure. Should an exploit be found, being current will be the easiest and quickest way to make the necessary update. I therefore recommend upgrading to the newest version for security reasons.

  15. moshu
    Member
    Posted 8 years ago #

    The newest is not always the most secure - so I strongly disagree! When WP 1.5 came out, it took 1.5.1.1 then 1.5.1.2, later 1.5.1.3, then 1.5.1 and 1.5.2 to get it "stable" and secure.

  16. eric1968
    Member
    Posted 8 years ago #

    OK, so I had the same problem, but I can address (in my rookie way) some of the questions posed. My situation was strange because I had no uploads folder, which after making and setting permissions with 777 worked (666 didn't).

    To Karne: On UNIX (or similar) based operating systems, you must let the OS know who can read and write to files and folders. When you use WordPress to upload an image, it wants to create a folder to store things in. WordPress will try to "write" to the folder "wordpress/wp-content/uploads/". If wordpress is not allowed to write into the folder, then you'll get a "permissions error", like Karne, myself, and I think Marco are seeing.

    Now if you are using a host with wordpress on the server, you need to navigate to the folder and change the permissions. If you know how to use the command-line, you can log in, navigate to the folder (mentioned by manstraw, and by default is like "wordpress/wp-content") and run the "chmod" command (listed by manstaw, try first "chmod 666 uploads" at the prompt, then again with '777' if it doesn't work) to set the appropriate permissions. I can't help too much more without particular knowledge of your installation of WordPress. I am using an installation locally on my machine here in OS X, but the process is almost the same.

    In my case, I went in the terminal (OS X's command-line interface) to the folder "/library/webserver/documents/wordpress/wp-content/" on my computer. I did the command "ls" to list the contents, and noticed I had no "uploads" folder in my "wp-admin" folder. So I did the "mkdir uploads" command to make the "upload" directory. Then I did the "chmod 666 uploads" command to set the permissions for the "uploads" folder. A quick check of the upload image capability of WordPress gave me the same error. So I tried the"chmod 777 uploads" command, which did work. I can now upload.

    Seems perhaps the "uploads" folder is missing from the base installation? Upgrades would have the "uploads" folder I think, and so only the noobs like me would run into this. Anyone?

    man I miss QA.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags