WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How can we have "403 Permission Denied" for our folders? (3 posts)

  1. marikamitsos
    Member
    Posted 2 years ago #

    Hello,
    We run a multisite/subfolders site on the root directory. We do have the very basic configuration to our .htaccess file. Nothing complicated.
    When someone types on the browser address
    "http://multisite.com/wp-content/blogs.dir/43/files"
    they can see ALL files under/in that directory. The same happens if they type eg:
    "http://multisite.com/wp-content/plugins/contents-of-the-box/languages/"
    We do NOT want that.
    We would like to block public directories access for all folders.

    We tried putting:

    #BEGIN Deny Directory access
    Options All -Indexes
    #END Deny Directory access

    in the .htaccess file but it was denied by the host system. Are you aware of some other way of achiving the above?

    Thank you for the help,
    marikamitsos

  2. Try just

    Options -Indexes
  3. marikamitsos
    Member
    Posted 2 years ago #

    Hello Ipstenu,
    and thank you, thank you, thank you!
    We applied it and everything works like a charm.

    Such a "simple" solution. Yet so valuable.
    The funniest thing is that we've been trying to convince our host to give us an answer to this for the last three days and all they would come up with was "We are sorry. We DO NOT support this kind of questions". They claimed that "this is a specialized to WordPress software rule", although we kept telling them it has nothing to do with WordPress itself, but with the server configuration.

    Thank you for providing the answer.
    marikamitsos

Topic Closed

This topic has been closed to new replies.

About this Topic